X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

The close tab icon ("x" box) does not appear on the tabs. Safemode and no add-ons, new window with only 2 tabs, still the same behavior. Why? How to fix?

Postáilte

It would seem the key is explained by the browser.tabs.closeButtons setting ( http://kb.mozillazine.org/Browser.tabs.closeButtons ). Mine is set to 5. If I set it back to the default of 1, then I get the close buttons ("x") showing up on the tabs again (or on the active tab only, if there are several). But 5 is not a valid value according the description. I'm sure that *I* did not change it to 5. So anyway, I changed it in safe mode back to the default of 1, and the close icons appeared immediately. Yeah! So then restarted firefox to have the add-ons working again. This caused it to be be automatically changed to 5 again. Grrrr!

Is there no way to trouble-shoot which add-on is screwing with the setting? I mean, other than turning them off one by one and restarting firefox each time? That could take all day.

It would seem the key is explained by the browser.tabs.closeButtons setting ( http://kb.mozillazine.org/Browser.tabs.closeButtons ). Mine is set to 5. If I set it back to the default of 1, then I get the close buttons ("x") showing up on the tabs again (or on the active tab only, if there are several). But 5 is not a valid value according the description. I'm sure that *I* did not change it to 5. So anyway, I changed it in safe mode back to the default of 1, and the close icons appeared immediately. Yeah! So then restarted firefox to have the add-ons working again. This caused it to be be automatically changed to 5 again. Grrrr! Is there no way to trouble-shoot which add-on is screwing with the setting? I mean, other than turning them off one by one and restarting firefox each time? That could take all day.

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • IE Tab plugin
  • 5.0.61118.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Unity Player 2.6.1f3
  • Delivery Network Acceleration by BitTorrent™
  • npdivxplayerplugin
  • DivX Web Player version 1.5.0.52
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin
  • Version 0.8.6c, copyright 1996-2006 The VideoLAN Teamhttp://www.videolan.org/

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

Tuilleadh Eolais

I'm currently running 16.0 beta, but the issue didn't start with the latest update. People have been running into this problem for years, so it would be nice to get to the bottom of this once and for all.

jscher2000
  • Top 10 Contributor
8793 réiteach 71928 freagra

You should be able to change the setting in about:config in normal mode. Does it change back every time you restart?

Do you run any tab-related extensions that might have as a feature changing the close button?

You should be able to change the setting in about:config in normal mode. Does it change back every time you restart? Do you run any tab-related extensions that might have as a feature changing the close button?

Úinéir na ceiste

OK, perhaps it changed back to "5" only because I did the editing while in safe mode. I tried the whole thing again, starting not in safe mode, and this time the reset to a value of 1 persisted. Admittedly, I also disabled two "older" versions of some add-ons that had newer versions active (I don't know why that situation would come about in the first place, but I was seeing 2 distinct versions active at the same time). At first, I disabled the add-on "IE Tab" in all versions, and still saw the parameter set to 1 after restarting, and then I re-enabled the latest version of "IE Tab" (2.0) and restarted again -- the value was still set to 1. Baffling. But perhaps someone can say for certain whether changes to the config while in safe mode are not retained?

In any case, I have fixed the problem by going to about:config and changing (resetting) browser.tab.closeButtons back to the default value of 1. Hope this helps someone.

OK, perhaps it changed back to "5" only because I did the editing while in safe mode. I tried the whole thing again, starting ''not'' in safe mode, and this time the reset to a value of 1 persisted. Admittedly, I also disabled two "older" versions of some add-ons that had newer versions active (I don't know why that situation would come about in the first place, but I was seeing 2 distinct versions active at the same time). At first, I disabled the add-on "IE Tab" in all versions, and still saw the parameter set to 1 after restarting, and then I re-enabled the latest version of "IE Tab" (2.0) and restarted again -- the value was still set to 1. Baffling. But perhaps someone can say for certain whether changes to the config while in safe mode are not retained? In any case, I have fixed the problem by going to about:config and changing (resetting) browser.tab.closeButtons back to the default value of 1. Hope this helps someone.
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159013 freagra

You can also check for problems with a user.js file if settings do not stick after a restart.

You can set the browser.tabs.closeWindowWithLastTab pref to false on the about:config page to prevent closing the last tab from closing that window and make a close button appear if only one tab is open.

You can also check for problems with a user.js file if settings do not stick after a restart. You can set the browser.tabs.closeWindowWithLastTab pref to false on the about:config page to prevent closing the last tab from closing that window and make a close button appear if only one tab is open.