Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox 12 is very slow compared with Chrome. IE9 when rendering this large page: http://www.ukwildflowers.com/Web_pages_intros_indexes/thumbnail_ZtoA_index.htm

  • 5 fhreagra
  • 26 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó cor-el

more options

This is the largest page on my web site ukwildflowers.com but has rendered perfectly OK with past version of Firefox. While Chrome and IE 7 render in seconds Firefox 12 takes minutes

This is the largest page on my web site ukwildflowers.com but has rendered perfectly OK with past version of Firefox. While Chrome and IE 7 render in seconds Firefox 12 takes minutes

Réiteach roghnaithe

Then if it works in Safe Mode, then it sounds like you have an issue with an extension. I would start in regular mode, go into your extension manager (type about:addons into the address bar, press Enter). Disable your extensions one-by-one until you find the issue.

Read this answer in context 👍 0

All Replies (5)

more options

It is fairly fast to me. The slowest part is downloading all those thumbnails, but it is the same sped in Firefox, Chrome, and IE (my internet isn't terribly quick). Have you tried starting Firefox up in Diagnose Firefox issues using Troubleshoot Mode to see if it is any faster? Also, try to update your graphics driver Upgrade your graphics drivers to use hardware acceleration and WebGL

more options

Updated graphics driver makes no difference. In Safe mode it is as fast as Firefox 11 was and comparable with other browsers - what does this mean?

more options

Réiteach Roghnaithe

Then if it works in Safe Mode, then it sounds like you have an issue with an extension. I would start in regular mode, go into your extension manager (type about:addons into the address bar, press Enter). Disable your extensions one-by-one until you find the issue.

more options

Yes thanks already done that. The problem is caused by Ghostery. Thank you for your help.

more options

See also:

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"