Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox will not load Googles Maps My Places data when I am logged in. It just says 'Server error. Please try again later..'

  • 8 bhfreagra
  • 8 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó bugrain

more options

I am running Mac OS X 10.5.8 and Firefox 10.0.1

All Replies (8)

more options


I'm sorry you're having this problem with maps. I haven't found a good answer to this, but have you tried clearing the cache? There are some other tips on googles map help site here:

Thanks, Michelle

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"
more options

I have cleared the cache and removed all cookies. The page still does not load, same response 'Server error. Please try again later.' What has changed in Firefox? I have over a hundred maps I have drawn for clients and I can't get at them. I can login via Safari and Opera and get to my work, but generally I do all my 'login' work in Firefox.

more options

Also tried the Google stuff from mluna and changed the JavaScript settings. No luck I am afraid.

more options

Do you only have that problem when you are logged in?

Does it help if you temporarily switch on Private Browsing?

more options

Private Browsing makes no difference at all.


more options

Just updated Firefox to 10.0.2. ...and made no difference at all! Still can't access Google Maps My Places.


more options

Had this problem too for some time. Was actually getting an Error 400 from the XHR request being sent when the 'My places' button was selected.

I appear to have resolved the issue by removing the GET data from the URL and simply hitting directly. After that, the 'My Places' button is now working again and my maps are back.

No real idea why this fixes it though.