Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Ever since updating to version 10, Firefox no longer inserts saved passwords. How can I fix this?

  • 10 bhfreagra
  • 1 leis an bhfadhb seo
  • 52 views
  • Freagra is déanaí ó Patty1515

more options

Password Manager remembers my passwords, but won't insert them at log in time. This began after updating to version 10. It will ask to save new passwords, but won't insert the old ones.

Réiteach roghnaithe

Hey Patty1515,

Have you looked at the Usernames and passwords are not saved Knowledge Base article? There is a lot of good information in there.

If it's only a particular site you are having issues with, you can also remove the cookies from that site to make the site forget you if you've created a remember me cookie by going to Tools > Options > Privacy > Cookies: "Show Cookies" There might be a "do not remember" cookie for that site.

Hopefully this helps!

Read this answer in context 👍 1

All Replies (10)

more options

Réiteach Roghnaithe

Hey Patty1515,

Have you looked at the Usernames and passwords are not saved Knowledge Base article? There is a lot of good information in there.

If it's only a particular site you are having issues with, you can also remove the cookies from that site to make the site forget you if you've created a remember me cookie by going to Tools > Options > Privacy > Cookies: "Show Cookies" There might be a "do not remember" cookie for that site.

Hopefully this helps!

more options

Thanks Matt. Turns out right now its only certain websites that Firefox used to put in the password for. One is Facebook the other is Gmail. Facebook inserted those passwords but no longer does. I have not done any new cookie settings than what I already had previous to version 10. So, I'm not sure if it has something to do with how version 10 perceives these log-ins that other versions did not. Interestingly, I removed the password for Facebook in the Manager thinking if I re-adding it would fix it. However, Facebook no longer asks me to remember that password unless I type an incorrect one. Maybe I need to re-boot my laptop. I'll try that next.

more options

Do you get a drop down list with choices when you click or double-click the empty name field?

more options

cor-el, no. I used to, but not since I upgraded. Now, nothing happens when I click or double click on the empty name field. I have two log-ins, one for me and one for my daughter. But for some reason, Firefox seems to have forgotten that the facebook log-ins even existed. Not sure what changed with the upgrade.

more options

Do you still see any saved names and passwords in the Password Manager?

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

more options

cor-el, yes. They are all there. However so far I'm finding that this is only affecting Facebook and Google (Gmail). Those passwords used to be inserted and they no longer are. In Facebook, it shows the last user name used but no password. In Gmail, it shows me a list of my user names to select, but when I do so, I have to manually type in the password.

more options

You do have enabled the password manager?

  • Tools > Options > Security: Passwords: [X] "Remember passwords for sites"

If only the name is filled then that can mean that Firefox is using save form data to fill that name.

  • Tools > Options > Privacy > History: "Remember search and form history"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

cor-el. This only started happening when I upgraded to version 10. I have the same hardware acceleration as I've always had. I'm only using the default theme. Nothing has changed except for the version of Firefox. All was fine until I upgraded. I want to go back to the previous version of Firefox. Can I do that? I have a desktop at my other location and you can be assured that when I get there, I will not upgrade it to Firefox 10.

more options

Did you try Safe mode to see if an extension is causing the problems?

You can also try to reset all preferences on the Safe mode start window or try to new profile.


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Thank you Matt. Turns out I had a facebook cookie saved that when I removed it, it solved the problem. I still have the gmail issue, but I can live with that (no saved gmail cookies).