Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

  • 8 bhfreagra
  • 4 leis an bhfadhb seo
  • 12 views
  • Freagra is déanaí ó sonster

more options

Google won't let me on Google+ until I upgrade (which I have, twice), but more astonishing, FF insists I need to upgrade (claims I'm running 3.5.1!

Réiteach roghnaithe

That worked! Thanks for your help.

Read this answer in context 👍 0

All Replies (8)

more options
more options

I inactivated all my add-ons. They are not the problem. But I don't want to mess with the user-agent. Any other ideas?

I can't believe Mozilla can't recognize it's own version of FF!!

more options

You can find the real Firefox version in the Help>About Firefox screen.
https://support.mozilla.com/en-US/kb/Finding%20your%20Firefox%20version
At this moment you are telling everyone that you have version 3.5.1, and that is what we recognize on this forum. We have no reason to assume that this is wrong.
Like the-edmeister said, it is possible that you useragent information is wrong and needs to be corrected.

more options

"About Firefox" on my computer verifies that I am using 7.0.1.

more options

Your Firefox UserAgent is messed up and is telling websites you visit that you are using Firefox 3.5.1.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Reset the prefs related to the UserAgent as described in the article that I hyperlinked in my first answer.

more options

I tried to make the mods, but Reset for general.useragent.locale is greyed out. The other options for useragent, don't appear.

Athraithe ag sonster ar

more options

Put this string - general.useragent. - in the Filter line at the top so you can see all the prefs related to the UA setting all at once. Reset any that are bold. Prefs that aren't displayed in a bold type are already at their default setting and don't need to be reset.

more options

Réiteach Roghnaithe

That worked! Thanks for your help.