Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Proxy choice does not maintain between Firefox restarts.

  • 14 freagra
  • 2 leis an bhfadhb seo
  • 1046 views
  • Freagra is déanaí ó jameyer3

more options

When Firefox is first opened I get "The proxy server refusing connection". I go into Tools > Options >Advanced > Network > Settings then select either 'No Proxy', 'Auto-detect', or 'Use system proxy settings' . Once one of these has been selected surfing works great until I stop and re-start Firefox then it is lost 'self-resetting' back to the "Manual proxy configuration" - HTTP Proxy 127.0.0.1. How do I make it maintain the 'No Proxy' between WS shutdowns and startups? Thank you. Jeff

Réiteach roghnaithe

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Read this answer in context 👍 0

All Replies (14)

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Thank you for the quick reply. Going to the HELP > Restart in Safe mode did nothing to help, still switched over to the Manual Proxy. Forgot to mention I am running FF 5.0.1 (upgraded due to issue) and XP V2002 SP3.

more options

Just saw this option on the messaging screen - System Details :

   Windows XP
   Firefox 5.0.1

Installed Plug-ins

   Garmin Communicator Plug-In 2.9.3.0
   npsnapfish
   Office Plugin for Netscape Navigator
   NapsterLink
   NPRuntime Script Plug-in Library for Java(TM) Deploy
   The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
   Adobe PDF Plug-In For Firefox and Netscape 10.1.0
   ActiveTouch General Plugin Container Version 105
   Shockwave Flash 10.3 r181
   Adobe Shockwave for Director Netscape plug-in, version 11.5
   iTunes Detector Plug-in
   GEPlugin
   Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
   4.0.60531.0
   Bing Bar
   Google Update
   Npdsplay dll
   DRM Store Netscape Plugin
   DRM Netscape Network Object 

User Agent

Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

Does that help? Although don't know why Netscape is there.

more options

To date, Tue., 30-Aug-11, 17:00 hrs., after multiple times manually setting, then setting again, the 'No Proxy' option inside Tools > Options > Advanced > Network > Settings still does not hold beyond each session; in other words between each workstation shutdown/startup or restart. My WS config is in previous notice from two weeks ago. Thank you in advance for any ideas or suggestions. Jeff

more options

-> Change the Network Settings back to Use System Proxy Settings -> Close Firefox

Now see this: Preferences are not saved - User.js file overriding preferences

-> Start Firefox

Check and tell if its working.

more options

Thank you for your reply. Ended up deleting all lines in USER.JS - no luck. After reading most of the the support page noted above looked at, did nothing to, PREFS.JS, however, the following three lines are in there - user_pref("network.cookie.prefsMigrated", true); user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 51939); I suspect that this is why it constantly gets reset; especially in light of the fact that USER.JS is now an empty file. Thank you. Jeffrey

more options

-> Open Firefox and type about:config in the address bar

  • When you see a warning, click I'll be careful, I promise button

1) In the Filter bar at the top of the about:config page, type network.proxy.http

  • right-click on Preference "network.proxy.http" -> click Modify -> Enter space " " as value -> click OK

2) Similarly, in the Filter bar at the top of the about:config page, type network.proxy.http_port

  • right-click on Preference "network.proxy.http_port" - > click Modify -> Enter Zero "0" as value -> click OK

-> Close about:config tab -> Restart Firefox

Check and tell if its working.

Athraithe ag Hasan ar

more options

Thank you for your reply. I am a little slow in picking the answer up because when I tried this part of the site was down. I followed the plan, including after reconfiguring, restarting my WS before restarting Firefox. The long and short it did not take. It may have comedown to one of two things -

   1.)  back(down)grade to an earlier release - currently at 6.0.1
   2.)  completely uninstall then use regedit to eliminate the scrapes and reinstall current release of 6.0.1

Is there another option that hasn't been tried or mentioned? Thank you. Jeffrey.

more options

Are you having any problems performing the steps mentioned in my last reply ?? IF yes, then what are the problems you are facing ??

more options

Réiteach Roghnaithe

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

Thank you all for the replies and suggestions. The last couple of days have been filled with trouble-shooting DBs which have not left me much time. Mha007 - followed your plan 'to the letter'. When I typed in 'network.proxy' two lines came up and I changed to your suggestions in one screen, two entries (two different variables) - if that makes sense. With no success. Cor-el - have not had a chance to attempt your suggestion will do so in the next couple of days. Thank you again. Jeffrey

more options

Thank you again to mha007 and cor-el. Finally, got things to work. It was a matter of creating a new profile. Also, suspect and truly do not know for sure, the McAfee Safe Site did not upgrade (nor is there one at this time) nor was it compatible to FF 6.x. Again, thank you for the directions. This appear to be up and running in a normal fashion again. Jeffrey

more options

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your Question

DO NOT click "Solved It" next to this reply

more options

Thank you. Have done so.