Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How can I get Firefox 4 to recognise that I have the latest Adobe Flash Player

  • 2 fhreagra
  • 19 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó SafeBrowser

more options

Firefox 4 refuses to play video clips. I keep getting a box telling me I need to have the latest Adobe Flash Player. I have just downloaded 10.3 and it is still not playing video clips.

Réiteach roghnaithe

You do not have Flash installed for Firefox. If you did you would see "Shockwave Flash (version number)" under Add-ons > Plugins. You can see the Plugins reported with your question; click "More system info...." to the right of your original question.

There are 2 versions of Flash, one for IE only (ActiveX version) and on for most other browsers including Firefox (Plugin version). You must update each one individually.

To install or update Flash:

  1. using Firefox download and save Flash from this link (save to your Desktop; easier for you to find): get.adobe.com/flashplayer
  2. when the download is finished, close Firefox (click Firefox button > Exit OR File > Exit, if using the Menu Bar)
  3. click or double-click the file you just downloaded
  4. on the left side of the install window, put a check mark in the box next to "I have read and agree"
  5. click on the Install button on the lower right of the install window; it will light up after you put the check mark in the previous step
  6. let the installation complete; it is quick
  7. using Firefox test your installation of Flash here: http://www.adobe.com/software/flash/about/
  8. for IE, repeat the process but use IE to go to the website in step 1.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You need to update some plug-ins:

Read this answer in context 👍 1

All Replies (2)

more options

-> Tap ALT key or press F10 to show the Menu Bar

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> go to Tools Menu -> Clear Recent History -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.

more options

Réiteach Roghnaithe

You do not have Flash installed for Firefox. If you did you would see "Shockwave Flash (version number)" under Add-ons > Plugins. You can see the Plugins reported with your question; click "More system info...." to the right of your original question.

There are 2 versions of Flash, one for IE only (ActiveX version) and on for most other browsers including Firefox (Plugin version). You must update each one individually.

To install or update Flash:

  1. using Firefox download and save Flash from this link (save to your Desktop; easier for you to find): get.adobe.com/flashplayer
  2. when the download is finished, close Firefox (click Firefox button > Exit OR File > Exit, if using the Menu Bar)
  3. click or double-click the file you just downloaded
  4. on the left side of the install window, put a check mark in the box next to "I have read and agree"
  5. click on the Install button on the lower right of the install window; it will light up after you put the check mark in the previous step
  6. let the installation complete; it is quick
  7. using Firefox test your installation of Flash here: http://www.adobe.com/software/flash/about/
  8. for IE, repeat the process but use IE to go to the website in step 1.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You need to update some plug-ins: