Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Cannot upgrade with accurate system requirements

  • 5 fhreagra
  • 16 leis an bhfadhb seo
  • 8 views
  • Freagra is déanaí ó Aspiring

more options

I tried to upgrade to 5.0 when it firsst came out. I checked the system requirements, which I thought I'd met:

Mac OSX 10.4 + Intel

When I tried, the program wouldnt run at all on my computer, so I was forced back to 3.6.16.

I want to upgrade, but it seems I cant.

Réiteach roghnaithe

http://www.mozilla.com/en-US/firefox/5.0/releasenotes/

http://www.mozilla.com/en-US/firefox/4.0/releasenotes/
http://www.mozilla.com/en-US/firefox/3.6/releasenotes/

http://www.mozilla.com/en-US/firefox/5.0/system-requirements/ http://www.mozilla.com/en-US/firefox/4.0/system-requirements/ http://www.mozilla.com/en-US/firefox/3.6/system-requirements/

For 4.0 and 5.0 Operating Systems

   Mac OS X 10.5
   Mac OS X 10.6

Recommended Hardware

   Macintosh computer with an Intel x86 processor


The 3.6.16 is old as the Firefox 3.6.19 is the most current, though since you are a Mac OSX 10.4 user, the 3.6.18 would be ok as the 3.6.19 was to fix a issue with certain fonts crashing Firefox on OSX 10.7 Lion.

http://www.mozilla.com/en-US/firefox/all-older.html

http://www.mozilla.org/security/known-vulnerabilities/firefox36.html

Read this answer in context 👍 1

All Replies (5)

more options
more options

This was not posted yesterday (or this morning) from what I can remember! But thank you alan.

more options

Please click the Solved It button next to the answer that answered or solved your Firefox support issue, it appears when you are logged in, so this thread gets marked as Solved to help other users who may have this same problem.

more options

Réiteach Roghnaithe

http://www.mozilla.com/en-US/firefox/5.0/releasenotes/

http://www.mozilla.com/en-US/firefox/4.0/releasenotes/
http://www.mozilla.com/en-US/firefox/3.6/releasenotes/

http://www.mozilla.com/en-US/firefox/5.0/system-requirements/ http://www.mozilla.com/en-US/firefox/4.0/system-requirements/ http://www.mozilla.com/en-US/firefox/3.6/system-requirements/

For 4.0 and 5.0 Operating Systems

   Mac OS X 10.5
   Mac OS X 10.6

Recommended Hardware

   Macintosh computer with an Intel x86 processor


The 3.6.16 is old as the Firefox 3.6.19 is the most current, though since you are a Mac OSX 10.4 user, the 3.6.18 would be ok as the 3.6.19 was to fix a issue with certain fonts crashing Firefox on OSX 10.7 Lion.

http://www.mozilla.com/en-US/firefox/all-older.html

http://www.mozilla.org/security/known-vulnerabilities/firefox36.html

Athraithe ag James ar

more options

Thanks James! That would offer better surfing I suppose (the 3.16.18 or .19). I appreciate you posting the link so I know where I can download it!