Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Why have you removed @font-face support from Firefox5 (Yes, tested on multiple machines, works fine in all other browsers & firefox4!)

  • 22 freagra
  • 86 leis an bhfadhb seo
  • 1858 views
  • Freagra is déanaí ó d_a__0

more options

.....

Athraithe ag rmwebs ar

Réiteach roghnaithe

@callumw, you have these rules:


@font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.ttf")} @font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.eot")}
@font-face{font-family:"Century Gothic";src:url("/font/gothic.ttf")} @font-face{font-family:"Century Gothic";src:url("/font/gothic.eot")}
@font-face{font-family:"Lithos Pro";src:url("/font/lithospro.ttf")} @font-face{font-family:"Lithos Pro";src:url("/font/lithospro.otf")}

Firefox is retrieving the second of the two font files in each case. Because Firefox doesn't support the .eot format, those two fonts are not going to work in Firefox. Can you try switching the order on those two and see whether that helps?

Edit: Century Gothic already is on my system, so the first one is the most critical.

Read this answer in context 👍 1

All Replies (2)

more options

I must admit that I'm really pissed now. My fonts worked a month ago in FF4. Now I tried a clean install - and it worked.

But it worked only for 10 minutes - I don't have to add, that I changed absolutely nothing on my site. After reloading the page, it just displayed the fallback-font. And now it works again - but I figured out what made the problem:

I had a startpage (http://wdrstndnetlabel.at) and I had two links to the same page (one was "http://wdrstndnetlabel.at/index.php" and one was "index.php#WDRSTND_001"). After klicking the absolute link the fallback-font was displayed and on the relative location.hash-link the fonts were displayed correctly.

Maybe a fix: Change internal links to relative - worked for me here. But I can't evaluate if it works without a fresh install of FF5.

Yet the behaviour of FF5 with @Font-Face seems hart to calculate. And this is why I keep using Opera for now.

more options

Watch out for the basedomain! After playing around a bit more I can say the biggest problem there for FF5 is the Domain. I worked on my site and suddenly the fontfaces won't work anymore. If there is the slightes clue for a different base-domain it just won't work. I had to different base hrefs: <base href="http://wdrstndnetlabel.at"> and <base href="http://www.wdrstndnetlabel.at"> Just the added 'www.' was enough to keep the fonts from loading.


Dear Firefox-people: I love your browser, but why is FF5 so shitty about embbeded fonts? I have all the fonts stored on the same server as all parts of my website, why should the different basedomain cancel the fontface?

  1. 1
  2. 2