Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

message that says: URGENT! Your version of Firefox is no longer protected against online attacks. Get the upgrade - it’s fast and free! I clicked to download version,try to open it, get warning about viruses, coming from firefox?

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 12 views
  • Freagra is déanaí ó the-edmeister

more options

Is there always a warning about virus downloads for Firefox?

All Replies (3)

more options

That is a legitimate message from Mozilla. Support has ended for Firefox 3.5.19. You need to upgrade to a newer version of Firefox. The hyperlink takes you to a download page for Firefox 4.0.1 and Firefox 3.6.17 is available here - http://www.mozilla.com/en-US/firefox/all-older.html

more options

"legitimate message" is not much to go on. I'd be only too happy to upgrade, but my end users are dependent on Java Initiator to load specific software interface to access Oracle database. that functionality is disabled in FF 3.6 and later... We aren't the hosts of the database, and our(my) pleas to the admins who host the third party front end to upgrade the JRE on the server are met with, "we're not going to reverse engineer their system..."

So while I'm stuck at 3.5.x, i'd like to know what it is in 3.5.18 or 19 that makes upgrade so Urgent, and I haven't found guidance in support.mozilla.org.

more options

See this - http://www.mozilla.org/security/known-vulnerabilities/

There is a version by version breakdown of Bugs that were fixed in each security update.