Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox wants to install update- it says my computer is not compatible BUT I am running OSX10.5.8 which it says is ok?

more options

on 5-19-11 firefox popped up and wanted to install UPDATES- I run it BUT it gave a message that it was not compatible with my operating system-but the list clearly says Mac 10.5-10,6? I run OSX10.5.8 What's the issue?

All Replies (2)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

more options

I don't feel comfortable roaming around to upgrade- i am running 3.5.19 and it is ok for the most part I am not dong anything technical and my computer just pays bills,E-mail and web browsing stuff!