Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

browsewithcaret

  • 16 freagra
  • 1 leis an bhfadhb seo
  • 102 views
  • Freagra is déanaí ó Xircal

more options

Hello,

I have the latest version of firefox 3.6.17 and absolutely not intention of changing to 4.0 as the "features" are too much and NOT very user-friendly for my use of a internet-browser.

I have however this problem.

browsewithcaret:

Which ever way, I try to set this browsewithcaret, I works only one way; ALWAYS. I have this "feature", but I don't like it at all.

Could you please fix this?

All Replies (16)

more options

You mean by hitting the F7 key? Just repeat that to turn it off again.

more options

Hello,

Thank you for a swift answer, however...

Could I borrow your F7, because mine doesn't work in firefox.

I know that, you have that feature. Regardless of how many times, I hit F7 or change the settings Tools/options/advanced/general the feature remains the same. cursor keys can scroll down and up.

Regards, Nikolaj

more options

Could you do the following please. In the address bar at the top, type about:config and hit Enter.

In the filter at the top, copy/paste the following setting: accessibility.browsewithcaret

The default is False. If it says "True", double click it to change it to "False".

more options

Hello,

I says "False".

Regards,

Nikolaj

more options

Could you double click accessibility.browsewithcaret_shortcut.enabled to change it to False please. It's only supposed to disable the F7 toggle key, but it might disable the blinking cursor you have at the moment too.

more options

Hello,

It's False too.

Regards,

more options

Very strange.

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

more options

Same thing in safe mode.

I'll just uninstall my add-ons, then and give you a reply.

Regards, Nikolaj

more options

I think you must have a corrupt Preferences file. Please see How to fix preferences that won't save

more options

Hello,

Thank you for your suggestion.

I did not work. Rename the prefs-file.

Changed browsewithcaret to false. Same result.

Regards,

PS.: Uninstall all 4 add-ons. With restart. Same thing.

more options

Not having much luck are we.

Could you try creating a new Profile please. See Profile Manager - Create, remove, or switch Firefox profiles

more options

If creating a new Profile doesn't work, I suggest creating a user.js file with Notepad.

So open Notepad and then without doing anything delete the entire name which is "New Text Document.txt" by default and replace it with user.js

Ignore the warning that the file will become unusable.

Then right click it and choose Edit from the menu and add this setting: user_pref("accessibility.browsewithcaret", false);

The file needs to be saved to C:\Users\{Username}\Application Data\Mozilla\Firefox\Profiles

A user.js file overrides the settings in about:config.

more options

Hello,

I tried both but only creating a new profile worked.

My bookmarks are easily restored, but not my usernames and passwords.

The user.js solution did not work for the old profile.

The path is C:\Users\{Username}AppData\Roaming\Mozilla\Firefox\Profiles\otinddtk.Default User

I not sure this is correct, but still. OS is W7 Ult.

Regards, Nikolaj

PS.: Have a nice weekend, when you get there.

more options

OK, if creating a new profile works, then you can transfer your old data to the new profile, instructions here: Recovering important data from an old profile

more options

Hello,

I know now what caused this error.

As I was loading a manual in pdf-format, I stop the tab. The pdf-viewer got activated and turn on browse with caret. Quite annoying.

Could you look into this?

Regards, Nikolaj

more options

Hi Nikolaj,

Thanks for letting me know. I'll pass it on.