Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Searching w/the google bar at the top right of the browser takes me to the google results page, as expected. However, after clicking a result it will no longer allow me to go back to the google results page using the left arrow button. How to fix?

  • 13 freagra
  • 4 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó cor-el

more options

Searching w/the google bar at the top right of the browser takes me to the google results page, as expected. However, after clicking a result it will no longer allow me to go back to the google results page using the left arrow button. How to fix?

All Replies (13)

more options

Right click the back button and select it from the list.

more options

That does not work, either. The back button is grayed out and will not perform any action.

more options

The back button will be greyed out if you didn't visit another site after opening a single site within that particular tab. If you opened a secondary tab and then accumulated history by visiting more sites, then right clicking the back button will give you the menu within that tab.

The only exception will be if you either have permanent private browsing mode enabled in Tools | Options | Privacy, or you hit CTRL+SHIFT+P to begin a private browsing session beforehand.

Athraithe ag Xircal ar

more options

I understand the functionality and am not in permanent private browsing. I open a new tab, search google, and click a result. The google results page is the first page. The link clicked on from that page is the second page. I should be able to return to the google page because it should be in the history as the first page viewed on that tab. This feature worked before and is no longer working.

This issue is happening now with 4.0 and was recently happening with 3.6. Not sure why this feature stopped working.

Athraithe ag sbnasir ar

more options

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

more options

Aha. So it does in fact work properly in safe mode. Now what? This is a newly re-imaged laptop with new install of Firefox, so I don't know why this is occurring.

more options

Do you have McAfee SiteAdvisor?

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
more options

I do have McAfee SiteAdvisor. Is that the culprit or should I try troubleshooting the add-ons?

more options

You can start with disabling McAfee SiteAdvisor to see if that helps to solve your problem.

more options

I disabled the McAfee SiteAdvisor extension, which is actually the only extension, and the back button works in the scenario described. Is there any way to keep SiteAdvisor on and have the back button work? It used to function properly like that before.

more options

You can try to update: /questions/753639

more options

That didn't work. Any other suggestions?

more options

You will have to contact McAfee and ask them how to fix this problem on your side.