Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

change storage time history

  • 6 fhreagra
  • 15 leis an bhfadhb seo
  • 19 views
  • Freagra is déanaí ó cor-el

more options

I want to change lenght of time my history is saved. rite now it is 30 days

Réiteach roghnaithe

In 3.6.16, the setting is located in Tools | Options | Privacy.

In 4.0, it seems to have been removed altogether and FF will save your history for 180 days by default.

I'm experimenting with the setting in about:config at the moment to try and set it to 10 days, but it doesn't appear to work as far as I can tell. The setting is called browser.history_expire_days which doesn't exist in FF4, so I added it.

Read this answer in context 👍 0

All Replies (6)

more options

Réiteach Roghnaithe

In 3.6.16, the setting is located in Tools | Options | Privacy.

In 4.0, it seems to have been removed altogether and FF will save your history for 180 days by default.

I'm experimenting with the setting in about:config at the moment to try and set it to 10 days, but it doesn't appear to work as far as I can tell. The setting is called browser.history_expire_days which doesn't exist in FF4, so I added it.

more options

It is no use to re-add those preferences to Firefox 4. Support for them have been removed. In Firefox 3 they still work, but no in Firefox 4 anymore.

more options

@ co-rel, thanks for the tip.

@ dennisw, it seems Mozilla wants us all to have bloated history files by linking the number of pages which can be held without influencing performance detrimentally to the machine's hardware.

So to reduce it to what we as users prefer to have, you now have to create a different setting which is places.history.expiration.max_pages

To create it, copy/paste it into the filter at the top to get a blank page, then right click and choose New and then Integer. Paste the setting into the field and click OK. Then add the number of days you want Firefox to retain in the next field (I only want 10 days). I've attached a screenshot to clarify the procedure.

more options

Thanks to all. Got both of mine set. My oldest is XP so I still have 3.6, an easy fix. dennisw

more options

Oh, oh...I discovered a problem. places.history.expiration.max_pages refers to the number of seconds that Firefox retains history, not the number of days. I just lost all mine. :(

So if you've added it to about:config, right click it, choose Modify and then click Reset to disable it.

more options

Quote:

for the sake of information we have two new hidden preferences:
places.history.expiration.interval_seconds is number of seconds between each expiration step, while places.history.expiration.max_pages is maximum number of pages that we will retain before expiring.