Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Adjust Bookmarks dropdown menu width

  • 17 freagra
  • 101 leis an bhfadhb seo
  • 2675 views
  • Freagra is déanaí ó Yorick

more options

After upgrading Firefox 4 I find the the Bookmarks dropdown menu is way too wide. How can this width be adjusted?

Réiteach roghnaithe

The width adjusts to the width of the largest Bookmarks entry. So You can try to adjust the names of the bookmarks in the Bookmarks Manager and make the text shorter.

Read this answer in context 👍 4

All Replies (17)

more options

Réiteach Roghnaithe

The width adjusts to the width of the largest Bookmarks entry. So You can try to adjust the names of the bookmarks in the Bookmarks Manager and make the text shorter.

Athraithe ag cor-el ar

more options

Thank you -- I did find a single stand-alone web address at the very bottom of my Bookmarks that was causing that problem.

more options

I have thousands of bookmarks from a 15 years of collecting. They are organized in folder hierarchy that goes six folders deep. Most of the bookmark names were "given" by the websites in question when I selected Bookmark This Page (or whatever the browser of the day called that function), so their width was predetermined. I will not be editing thousands of bookmarks to make them shorter. I won't even go so far as to agree to edit bookmarks in the future to make them shorter. Every browser I have ever used, including Firefox 3.6 only 'displayed' the first 40 (the exact number is a guess) characters of each bookmark or folder name when I selected that menu. Further, when I went down the tiers, each tier also only displayed the first 40 or so characters. If a name was longer, the display would end in an ellipse which noted to me that the name was wider than the 40 characters.

With the new Firefox, navigating to the bottom tier is a nightmare. The menu is essentially on the left side of the window, but the next tier down is off the right side as there are long names. Going down through the tiers, the display goes all the way back left and then back right because of name width at each level. On some selections, I have had to pick up my mouse and place it back down because I have scrolled off the edge of my table.

I thought that the OP had my problem. I suppose he or she did, to some small extent, but I will not 'fix' my problem by editing the width. I don't want to lose the information in the names, nor do I want to spend that much time editing thousands of names. This is the first browser that ever did this to me and I would hope there is some solution that tells the browser to limit the menu width to some fixed measurement. Given how little talk there is about this and the fact that the OP seems satisfied with editing, however, I doubt that there is such functionality. I will probably go back to a previous version of the browser to restore this functionality. I don't do very much that requires add-ons or plug-ins. But I visit scores of bookmarks everyday, so this impacts me all the time.

I just thought to add that when I Organize Bookmarks (Show All Bookmarks in this version) a popup window appears, in which I can easily adjust the column width to show more or less width-of-names. It is here that the information that I do not wish to truncate can be seen and used. Or not. As the case may necessitate.

more options

Perhaps this isn't the place for this Reply, but given the new problem, I think it is appropriate. I posted to this question almost an hour ago. On the left side, under my handle, I see that there have been two 'answers.' However, I can't see them here, in my profile page (clicking on my handle), in my dashboard, or in my email. Where do I see those 'answers?'

more options

Hmm, I just learned by posting that the two 'answers,' which are now three and about to be four, include my responses and cor-el's response. I am now back to waiting for a response to my first post.

more options

You can try code like this in userChrome.css to set a max-width. I haven't tested this, so give it a try and adjust max-widths to your needs.

Add code to userChrome.css below the @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#bookmarksMenuPopup .bookmark-item { max-width:500px!important; }

#personal-bookmarks toolbarbutton.bookmark-item { max-width:100px!important; }
#personal-bookmarks menupopup .bookmark-item { max-width:500px!important; }

#BMB_bookmarksPopup .bookmark-item { max-width:500px!important; }

.bookmark-item[livemark] .bookmark-item { max-width:none!important; }

more options

Thank you for your response cor-el.

I have never heard of userChrome before this, so this is what I did:

  • I went to the Help menu and chose Troubleshooting Information
  • Under Application Basics, I hit the Show in Finder button
  • In the resulting folder window, I looked in the sub-folder named Chrome
  • I brought up the file titled userChrome-example.css
  • I copied the text from the resulting Safari window
  • From the Macintosh Applications folder, I opened TextEdit
  • I pasted the text
  • I copied the suggested text from your response above
  • I pasted it under the @namespace line as indicated with one line between them
  • I saved the file, although it required me to use a different extension, in this case userChrome.css.odt
  • I moved the file into the Chrome folder and changed the extension by removing the .odt
  • I closed all windows, quit all applications, and shutdown
  • I restarted and opened Firefox

There was no change. While I was retracing my steps to type this, I notice that the file I saved is filled with garbage and I don't know why. So, I moved it to the trash.

I don't know what went wrong, but it probably has to do with saving it with a different extension.

more options

I'm unclear - is Firefox's position that this problem is solved by users going into their Bookmarks and shortening their length?

If so, I would like to make sure they understand that for this user, that is certainly not a solution.

more options

It shouldn't be necessary to change the file type while saving. Make sure that the file name is userChrome.css and didn't get saved with a hidden .txt file extension that Windows may hide.
You can see the file type in the properties via the right-click context menu.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

This code works for me in Firefox 4.


/* Set max-width of items on the Bookmarks Toolbar*/
#personal-bookmarks toolbarbutton.bookmark-item { max-width:80px !important; }

/* Hide icons on Bookmarks Toolbar */
#personal-bookmarks .toolbarbutton-icon { display:none !important; }

Athraithe ag cor-el ar

more options

I had the same problem. Moved all bookmarks in my bookmarks menu that weren't organized into folders into the unsorted bookmarks dropbox and my Bookmarks dropdown menu went back to normal.

more options

Thank you cor-el, this solved part of the problem for me (the drop down bookmark menu on the toolbar now has a rational width regardless of how long some bookmarks title fields are).

I am on a mac though (Firefox 5.0, Mac OS 10.5.8), and the Top of the Screen Menu for Bookmarks still has the same "too wide because of silly long bookmark titles" problem; do you know what the #personal-bookmarks variable is that would adjust the width for that drop down menu?

Even if you knew a page that lists a lot of these variables, that would help - I may be able to find it if I had that. I've been googling but no dice so far.

more options

Unfortunately on a Mac the Bookmarks menu on the menu bar is maintained by the Mac OS and not by Firefox, so you can't use code in userChrome.css to set a max-width. Your only option on Mac is to edit long names and make them shorter.

more options

Unfortunately, wrong reply; and to cor-el - I would suggest you learn the subject before giving such advices.

Of course, Mac OS should (and does) allow to display menus of any width (it would be useful for bookmarks menu, if it didn't contain subfolders) but width of the menu can be limited, like it is done in almost any other browser out there, like Safari, Chrome, Firefox 3.6 etc. So, if developers of Firefox forgot to limit the width of menu /didn't know how to do it, it does not mean user will now need to edit their bookmarks.

Firefox exists for the users, not other way around, right?

more options

The bookmarks menu is out of control for Firefox after it has been passed to the OS otherwise the code in userChrome.css would have worked as it does on other platforms like Linux and Windows.

That limitation of the width, that previous versions of Firefox have, has been removed deliberately in Firefox 5.
Maybe an extension or theme can fix this and restore the max-width for bookmarks items.

more options

Limitation of the width may be removed deliberately, but it IS a mistake. And, asking user to limit the length of bookmarks names is not a solution. Of course, Mac OS is not Windows nor Linux, and if one is writing application for this OS, one will need to learn how to do it properly.

Problem with Firefox is that I see such problems elsewhere, and they are not problems of coding itself but more like the result of fundamental misunderstanding of basic things. Like, storing passwords without any protection (or, alternatively, asking master password every time you want to enter the password) is plain wrong, and discussions in support forum reveal that somebody without a clue about security is in charge. Similar thoughts about this bookmarks menu issue - obviously, somebody made a decision without understanding what he was doing.

Finally, again - if Mac OS X allows to limit bookmark menu width for any other browser out there, it equally allows this for Firefox too.

more options

Update- installed Firefox 5.01 on mac mini, not a very powerful machine.

Now, dropdown bookmarks menu (that one which is affected by userChrome.css), does not scroll at all if focus is on the folder; when scrolling it uses like 50% CPU!!

In other words, guys at Firefox either need to try to code properly (for Mac) or - not to fix something that is not broken (bookmarks menu was working ok in FF3.6).

more options

The idea that the bookmarks menu in Firefox is controlled by the MacOS is in no way accurate. If that were so, then the bookmarks menu list in previous versions of Firefox would ALSO have been excessively wide instead of limited. I just updated from Firefox 3.6 which is still in use on my older computer.

The problem with overly-wide bookmark names also affects the History menu. See attached picture. Note that most of the items in the list are from Firefox's help. Some of the items in the list have been abbreviated, but ever-so-slightly, and this is still taking up too much space on the screen.

I have not found any of the code posted by cor-el to work on the Bookmarks menu.

As there are multiple complaints about this issue, perhaps Mozilla should change its code back for the bookmarks menu, or at least provide a toggle for it?