Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How can I put the personal bar above tabs ?

  • 13 freagra
  • 26 leis an bhfadhb seo
  • 915 views
  • Freagra is déanaí ó henryfm

more options

In Firefox 4, How could I move the personnal bar above tabs? Is it possible? Because personaly with the new tabs bar on top I find that it should be better to have my bookmarks on top of this. Thanks by advance. (ps: off topic, I just don't understand why removing things from the user: dropdown history list in the forward/backward buttons wihtout giving him the choice somewhere..)

Réiteach roghnaithe

Seems to be under View>Toolbars now

Read this answer in context 👍 0

All Replies (13)

more options

Press the F10 key or use "Firefox > Customize" to make the Menu Bar and other toolbars visible and remove the check-mark on "Tabs on Top" to place the tab bar in the old position.

more options

Thanks but that is not what i want! :)

I don't want "tabs bar" on top but "personal bar" ( with my bookmarks) on top.

more options

If you remove the check mark of Tab on Top then the tab bar will be placed just above the browser window and all toolbars will appear above the tab bar. Tabs on Top is selected by default on Linux (the gray Firefox menu button on the tab bar isn't).

more options

1323 solutions, you're not grasping the problem. By default firefox 4 has the following setup:
menu bar
tabs bar
navigation bar
bookmarks bar
page

Where you get the menu bar outside of the tab and the bottom three bars inside each tab like follows:

menu bar 
|tab 1|tab 2| tab bar
         /         \
------------------------
|nav bar                     |
|bookmark bar          |
|----------------------|
|web page                  |
------------------------

What is wanted is this:

menu bar 
bookmark bar          
|tab 1|tab 2| tab bar
         /         \
------------------------
|nav bar                     |
|----------------------|
|web page                  |
------------------------


Is there any way to do this?

Athraithe ag cor-el ar

more options

Grr! Stupid thing butchered my text image. It was supposed to look like this:

more options

Thanks theripper!! you have got it! too bad you have no solutions to it :) Thanks anyway to have clarified my though.

more options

There is a way: You need to install an Add-On called Stylish, and a Style called "Firefox 4: Bookmarks toolbar above tabs" from userstyles.org that does exactly what you want. It's free and done in a minute, check here: firefox-4-bookmarks-toolbar-above-tabs

I also find this order - menus / bookmarks toolbar / tabs / controls within tab - the most logical and comfortable, but couldn't get it before FF4. Happy I can do so now!

Regards, G.

more options

Regarding your comment "removing things from the user: dropdown history list in the forward/backward buttons": try right-clicking the forward/backward buttons ;-)

FF4, I find, has done some things to improve usability on smaller screens, while optimizing handling. It just takes some getting used to...

more options

You can also place such CSS code to modify the Firefox user interface in a file userChrome.css in the chrome folder in the Firefox Profile Folder

Add code to userChrome.css below the @namespace line.


These are the defaults in Firefox 4, so a value of 6 as used in the Stylish code places a toolbar right below the menu bar.

#toolbar-menubar {-moz-box-ordinal-group: 5;}
#nav-bar, #PersonalToolbar {-moz-box-ordinal-group: 50;}

#TabsToolbar {-moz-box-ordinal-group: 100;}
#TabsToolbar {-moz-box-ordinal-group: 10;} /* Tabs on Top */
more options

Thanks georgS. But Effectively I would prefer the extensionless solution :) So thanks cor-el! But I think I miss something because it does not work .. I have tried severals things without success. First I did not have a namespace line (but it did not work more after..) then I tried to add

  1. PersonalToolbar {-moz-box-ordinal-group: 6;}

without success too..

Thanks for your help!

more options

You need to add the important flag to override the current setting of 50

#PersonalToolbar { -moz-box-ordinal-group: 6 !important; }
more options

Thanks cor-el! You are my savior!

more options

Réiteach Roghnaithe

Seems to be under View>Toolbars now