Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to disable auto reload Tabs on Firefox-Launch

  • 8 bhfreagra
  • 42 leis an bhfadhb seo
  • 12553 views
  • Freagra is déanaí ó fastfate

more options

Hi,

i have an old Laptop and it takes a lot of time to launch Firefox if there are a lot of tabs from the old session.

How can i prevent Firefox to reload all the old Tabs on startup?

Thanks for your help Florian

Réiteach roghnaithe

OK if you are using TabMixPlus, reset or set this FireFox setting.

  • extensions.tabmix.autoReloadContent

Credit where credit is due, use the:

  • AboutPages extension

To check-out options!

To firefox and tab-extension programmers (who probably don't read this) ... STOP making decisions for me. I'm often using a mobile broadband and reloading tabs or pages I don't need "NOW" is not only time-wasting, it costs me money I don't need to waste!

Not everyone has a T1 connection for firefox-sake.

Oh, my apology. Yes I did test this with my most recent Session Manager session restore. The tabs that didn't reload while the mobile broadband was turned-off; did NOT reload after turning the internet back-on, when I clicked the Tab. Excellent, just what I need.

Good luck fellow web surfers!

Read this answer in context 👍 0

All Replies (8)

more options

You can do that with the BarTab extension. With that extension tabs will only load when you select them.

https://addons.mozilla.org/firefox/addon/bartab/

more options

Thank's Tony, this addon solves my problem.

Thank you so much

more options

But what if you're using Firefox 4.0? BarTab isn't compatible with this version. Morbus says that this feature is built into FF 4.0. Is that true?

more options

For Firefox 4 you can change a hidden pr3eference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.sessionstore.max_concurrent_tabs, double-click on it and change its value to 0 (zero), this will make Firefo only load the tab when you select it.
more options

When FF (6.02) starts, all the content in every tab from my last session is there - from the cache. Then is starts to reload all the (50+) tabs, makes the browser unusable until it's finished. Why? How can I disable this behavior?

more options

Réiteach Roghnaithe

OK if you are using TabMixPlus, reset or set this FireFox setting.

  • extensions.tabmix.autoReloadContent

Credit where credit is due, use the:

  • AboutPages extension

To check-out options!

To firefox and tab-extension programmers (who probably don't read this) ... STOP making decisions for me. I'm often using a mobile broadband and reloading tabs or pages I don't need "NOW" is not only time-wasting, it costs me money I don't need to waste!

Not everyone has a T1 connection for firefox-sake.

Oh, my apology. Yes I did test this with my most recent Session Manager session restore. The tabs that didn't reload while the mobile broadband was turned-off; did NOT reload after turning the internet back-on, when I clicked the Tab. Excellent, just what I need.

Good luck fellow web surfers!

Athraithe ag aplaypus ar

more options

Without using any add-ons, there is a really simple solution I discovered last night. In the General tab of the Options menu, select the "When Firefox starts" option "Show my windows and tabs from last time", then tick the "Don't load tabs until selected" box below. you can then set the "WFS" option to homepage or blank tab, and if you save a session, the tabs will no longer automatically refresh when you re-open FF

more options

Hi.

Change about:config -option: browser.tabs.loadInBackground;true to browser.tabs.loadInBackground;false

Explanation: Open a new firefox-browser tab, enter "about:config" in address field (enter without "", later "" are to highlight options too). Confirm you will be carefull (Be carefull not to change other option if you do not know what you do / what they are for!). Enter "loadinbackground" in search field (e.g. applied filter). Change option "false" to "true" by doubbleclick line: browser.tabs.loadInBackground The new line should look something like: browser.tabs.loadInBackground; changed by user; boolean; false. Close tab, reopen browser. You got load on tabclick!

Best, mwp (p.S.: To Pageadmin: Posts format is reset on submit!)