Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Bold font problem only in Firefox

  • 12 freagra
  • 345 leis an bhfadhb seo
  • 9644 views
  • Freagra is déanaí ó KINGPEACH

more options

For as long as I can remember, there has been a problem with bold fonts in Firefox. I don't know why this is happening. Here is a pic of what I mean, http://i35.photobucket.com/albums/d190/eyyo/boldproblem1.png . I know this has happened to other people as I've seen other posts about the same problem, but none of the solutions I found have worked. Does anyone know how I can fix this? Thanks.

Athraithe ag cor-el ar

All Replies (12)

more options

A possible cause is a corrupted font that makes Firefox switch to another, bold, font.

Some Catalyst drivers for ATI graphic display cards have also been reported to cause that issue.

See Some text shows up bold after upgrade

more options

Thanks for the reply. I've already seen that support page and have reinstalled those fonts and it didn't fix the problem.

more options

On the digg.com/news site the Helvetica font is specified:

font-family: "Helvetica Neue",Helvetica,Arial,sans-serif;

The Helvetica font is known to cause all kinds of issues in Firefox if you have an old Mac bitmap version installed. You can try to uninstall the Helvetica font and all its variants to see if that helps.

more options

I have seen this issue on ALL my pcs, I think it has to do with the installation of Adobe CS4 (in my case) because everything looks fine in FF after a fresh windows/ff install but after installing CS4 I get the issue. I have seen many people asking what the problem fix is but I still haven't figured out a way to get rid of it. The first time I asked about this was over a year ago and still haven't found a fix, this is highly annoying, to the point that I am using Chrome as my main browser, though I would prefer FF.

@cor-el: I didn't have the Helvetica font by the time I saw bold font the issue again.

It really IS an issue Firefox needs to address, I do not see this problem on any other browser, None.

Athraithe ag hexdj ar

more options

Which fonts does Adobe CS4 install?

more options

Again, it's only in Firefox - in other browsers and on desktop the fonts are fine. I tried re-installing Windows core fonts, Arial, etc, re-installed Firefox, deleted all my settings and preferences - the fonts in Firefox are still bold.

Here's a side-by-side comparison to make it more clear: (And it's strange - it's not all the fonts that are bold, it's selective, some writings are normal and others are bold)

UPDATE I just checked the attached file and it confuses the issue because it's displayed resized and so everything looks not normal! Download the attached image to your desktop to view it in full size and see the font problem!

Athraithe ag hikki ar

more options

There clearly is an issue with FF and fonts displayed bold. To me it started after upgrading to FF5 and moreover happens randomly. The page displayed in bold fonts with messed up layout. Then after restart it looked ok, Happens repeatedly. Other browsers are ok.

more options

You may have some old Type 1 fonts installed that aren't working in Firefox.

more options

I've tracked the problem down to the combination of Type 1 fonts and FireFox. It seems to have been around for ages (see e.g. [https://bugzilla.mozilla.org/show_bug.cgi?id=396315] and related pages) and is still not fixed. For example, the simple HTML shown below (with *any* of my Type 1 typefaces) shows corrupt text on my system (XP SP3) in FF7.01 but is fine in Chrome:

<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> <title>Test</title> <style>body{font:33px "Frutiger"}</style> </head> <body>Test text</body>

more options

Here's the fix that works for everyone:

- Right click firefox.exe in the installation folder.

- Go to Properties > Tick checkbox "Run this program in compatibility mode for"

- Choose "Windows XP (Service Pack 2)"

- Click "Apply" and "OK"

- Problem Fixed

Now, would the Firefox developers please apply this very difficult fix in your next release?

Athraithe ag JeremyT ar

more options

I have the same problem and solved it. In my font folder there was Arial, but the font was not complete. I copy a new arial from another pc and now ff work Hope that this can help someone

more options

This worked Thanks I had the same issue and your Fix was exactly what it was...!!

Here's the fix that works for everyone:

- Right click firefox.exe in the installation folder.

- Go to Properties > Tick checkbox "Run this program in compatibility mode for"

- Choose "Windows XP (Service Pack 2)"

- Click "Apply" and "OK"

- Problem Fixed

Now, would the Firefox developers please apply this very difficult fix in your next release?

Athraithe ag KINGPEACH ar