Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

get external program to launch Firefox with correct profile

  • 2 fhreagra
  • 5 leis an bhfadhb seo
  • 39 views
  • Freagra is déanaí ó the-edmeister

more options

I launch Firefox with -p switch and profile name. How do I get Firefox to choose that profile as default without using that switch? - needed so that when my mail program launches a browser (as specified in Windows), it launches Firefox with correct profile. At present it uses correct version of Firefox (I also have a Minefield beta installed) but wrong profile.

All Replies (2)

more options

1) External programs are going to launch the Profile that is showing as the Default=1 Profile in the profiles.ini file. If that particular Profile isn't even listed in profiles.ini, that's your problem.

2) If that Profile is already running using the -no-remote switch to launch it, it won't be seen. That switch basically tells Windows to ignore that process.

Are you also using the -no-remote switch?

Is that Profile not listed in the profiles.ini file?

more options

Thanks, the_edmeister. To answer your questions, No, I never use the -no-remote switch. My QuickLaunch shortcut specified both the version of Firefox (by calling it with full path) and the profile (by using the -p switch).

My profiles.ini starts with the entry StartWithLastProfile=1 It listed three profiles, including the desired one, but it did indeed have Default=1 against a different profile. I moved this line to the end of my desired profile - why didn't I do that earlier? - and lo, the external mailer now launches Fx with the right profile, and the shortcut works even without using the -p switch to specify the profile. Problem solved. Thank you.