Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

My back button stopped working, not saving pretyped info in my cache.

  • 3 fhreagra
  • 23 leis an bhfadhb seo
  • Freagra is déanaí ó cor-el

more options

I have cookies enabled, I'm not using private browsing. My back button stopped working on the last Firefox update. As well, if I enter my username in sites I visit on a regular basic, ie) Facebook or my work email. It doesn't auto complete my username anymore.

All Replies (3)

more options

Make sure that you not run Firefox in Private Browsing - Use Firefox without saving history mode. In Private Browsing mode some menu items are disabled (grayed) and features like visited links and disabled and not available. You are in Private Browsing mode if you see "Tools > Stop Private Browsing", possibly grayed. ..... You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history Uncheck: [[ ] "Automatically start Firefox in a private browsing session"

more options


I have also had this problem now for months and it is very intermittent in that I can click the back button (right click) and I can go back to the 5th or 6th lonk in the history sometimes however very rarely if ever can I go back 1 or 2 or even 3 links back, if I click on them it just does absolutely nothing.

Nothing is grayed out, no error message appears it just doe not work properly and is extremely inconsistent. It seems to have only started since version 3.6 (at least I do not remember this being an issue more than a few months back) and I worked at Netscape Communications Corp until they were taken over by AOL and have been using Mozilla since there was a mozilla to use and never had this issue previously.

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.