Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox Address Bar Goes to Bing

  • 73 freagra
  • 815 leis an bhfadhb seo
  • 14867 views
  • Freagra is déanaí ó JohnMartoccio

more options

When typing into the address bar everything goes to bing search now. I have done everything from changing keyword.url to starting in safe mode to completely uninstalling and reinstalling Firefox. Nothing works and it always goes back to a bing search whenever I type anything in.

Réiteach roghnaithe

hijack firefox


solved by uninstalling this update. kb982381

Read this answer in context 👍 0

All Replies (20)

more options

I had the exact same problem and had uninstalled all toolbars, deleted the contents of Search Helper, and did not have KB982381. Using the NoRedirect firefox extension with the instruction from Amir.

"...install it then make a new regexp pattern "http://www.bing.com/search?" and ONLY click/check "dns error", not "allow" or "source". the interface (to me) was a bit scary, because the other websites were typed in an odd manner, but just do it this way, worked for me and was easy. "

WORKED INSTANTLY!

more options

I have a very similar, but not identical problem. I'm using a Mac and my single word searches are redirected to a wowway search engine. Wowway is a local internet provider in my area, but is NOT my provider. Multiple word searches still go through google as i've set it up in keyword.url - This thread is the closest I've come to finding a solution to the problem, but since I'm not using Windows, I don't know where to go from here...

more options

Rachel: if you can get the same extension as I mentioned before and that is mentioned above, it should work for you as well. instead of "http://www.bing.com/search?" though, you put the body of the webpage that you are directed to. for instance. if it directs you to "www.wowway.com/search?" or something like that, then put that in instead. im not sure how FF works for macs, but I assume that you can use the same extensions..

more options

I had this problem some time in the past and solved it by changing the keyword - option. But this time this option is already set right and bing still appears. It's driving me crazy...

more options

I had exactly the same problem, and the config stuff and everything else didn't work for me. I went into internet explorer, clicked on Tools - Internet Options - "Settings" under "Search: Change Search Defaults. Two were listed: google and live search. I clicked on live search and then "remove". I restart firefox and presto, my address bar stopped binging me.

more options

Okay, so the removal of the files from "C:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies\Low" worked for me - for a while. Now Bing is back (and so is the IECompatCache folder, yet deleting is has no effect this time).

I also tried Dan's advice although for me IE's only search engine listed was indeed Bing. So I added Google and after that removed Bing but with no success. So now I'm stuck with this again.

more options

I removed KB982381 and restart my computer then the shitty bing gone :)

more options

I have never updated Windows 7 since installing it, I do not have the KB982381 update. Neither do I have a Cookies folder under Windows in AppData and I have exactly the same problem.

I did have a "C:\Program Files (x86)\Microsoft\Search Enhancement Pack" folder, though.

This is extremely annoying.

more options

From Amir:

"It appears that this is an issue with dns hijacking. I am now using an extension that I needed when I was with bell, now I'm with rogers and apparently I need it again. It's called "NoRedirect." install it then make a new regexp pattern "http://www.bing.com/search?" and ONLY click/check "dns error", not "allow" or "source". the interface (to me) was a bit scary, because the other websites were typed in an odd manner, but just do it this way, worked for me and was easy. "

Amir saved me too. Only thing that worked was installing noRedirect and following his instructions. Hope it last...

more options

I have the same problem. If I type 1 keyword in the address bar, bing will come instead of google, that's irritating.

What I figured out is somehow Microsoft set my DNS siffix to "mshome.net". So I went to regedit and empty all the entry with "mshome.net" (find it and manually set it to blank). After resetting my connection and flush the dns, everything returned to normal.

Hope this can help everyone

Vu

more options

Hello Vu, thanks for your idea. But look to the attachment. There are 6 entries in my registry, all with "mshome.net". Does my wlan-net work in the future if I blank "mshome.net" out of those entries? Best regards from good old Germany, Didi.

more options

Réiteach Roghnaithe

hijack firefox


solved by uninstalling this update. kb982381

more options

@DiDi: I doubt It would cause any problem to your wlan, however, If you worry, backup the regedit before you try.

There is a setting in your TCP/IP connection, you can also configure it there (properties -> Internet Protocol Version 4 -> advance -> dns ).

also flush the dns cache using : ipconfig /flushdns

more options

Vu, thank´s a lot. It´s only, why the network-name of my computers is "mshome.net". But you are right, I can save the registry or can make a sytemrestorepoint first.

Best Regards, Didi

more options

While I remain irked with Microsoft for this issue, Amir's solution seems to work very well. Until there can be a solution to prevent Microsoft's hijack, this is an excellent work around I would urge you to consider if nothing else has worked for you in removing the Bing redirect.

more options

Após instalar o Thunderbird 3 não consigo abrir o Firefox 3.6 simultaneamente e vice-versa. Há incompatibilidade?

more options

Hi. Ive been having the same problem, all though it seemed to have been fixed after I deleted the update the problem started again. If you're like me and have tried uninstalling the update,playing around in about:config,playing around in internet explorer and deleted those files in the roaming app data and still are having the same problem i advise doing what Dang Hoang Vu suggested. It was much easier that i thought as i just searched for mshome.net in the regedit and deleted everything i could, then flushed the dns which was also very easy. So far so good. Thanks for the fix.

more options

Thanks to the chap that mentioned setting mshome.net entries in the registry to blank, then resetting the network connection, then flushing the DNS. This is the only thing that worked for me - I have Windows 7, uninstalling the update didn't work, I don't have a Bing bar, or a Microsoft/ folder in either Program Files or Program Files x086.

It's nice to have Bing gone.

more options

thanks Dang Hoang Vu, that seems to fix my problem too

more options

Interesting, this problem keeps coming back. I now have no "mshome.net" entries in my registry, but on booting the PC, the Awesome Bar reverts to Bing for single-keyword searches.

Resetting the network connection ("disable" then "enable"), followed by flushing the DNS ("ipconfig /flushdns" at the CMD command line) causes single-keyword searches to once again revert to Google as desired. However, I have to perform this each time I turn on the PC.

As stated above, removing the KB update didn't work, and I have no Microsoft/ folder, nor Bing toolbar or searches installed. Only the above DNS flushing seems to work - but it's a temporary fix, until I next log in.

Any thoughts?


Thanks,

H

  1. 1
  2. 2
  3. 3
  4. 4