Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox Address Bar Goes to Bing

  • 73 freagra
  • 815 leis an bhfadhb seo
  • 14868 views
  • Freagra is déanaí ó JohnMartoccio

more options

When typing into the address bar everything goes to bing search now. I have done everything from changing keyword.url to starting in safe mode to completely uninstalling and reinstalling Firefox. Nothing works and it always goes back to a bing search whenever I type anything in.

Réiteach roghnaithe

hijack firefox


solved by uninstalling this update. kb982381

Read this answer in context 👍 0

All Replies (20)

more options

wow, Rob is completely right. Multiple word searches are being handled properly , and one word searches go to bing.

This is really annoying. Has anyone figured it out yet?

more options

OP here.

Uninstalling KB982381 like suggested worked for me. I don't know if it will show up again raindomly though.

more options

Hi. I have the same problem. There is neither a "...\search helper" folder in my system (BUT i have a "C:\Program Files (x86)\Microsoft\Search Enhancement Pack" folder) nor a "search helper" firefox plugin. I tried uninstalling the KB982381 update, but it didn't fix the problem. I have to say that the bing hijack shows up after a while since windows startup.

more options

Go to the Microsoft site for Microsoft Security Bulletin MS10-035 (link below), scroll down to the bottom, scroll up a tad, see "Support", has toll-free numbers with "no charge" support:

Link to MS10-035: http://www.microsoft.com/technet/security/bulletin/ms10-035.mspx

Maybe if they they bombarded with calls from dissatisfied users, the "gods" at Micros**t will get the message, probably not though.

more options

Rick C:\Program Files (x86)\Microsoft\Search Enhancement Pack is the equivalent in Windows 7. The (x86) indicates 32-bit applications. -Is there a "firefoxextension" folder in that folder? -If so, did you try to delete it? -Did you restart Firefox after removing KB982381? -If you do have a "firefoxextension" folder in C:\Program Files (x86)\Microsoft\Search Enhancement Pack delete it or rename it, then restart Firefox.

Let us know your results. I may help others.

more options

Latest news on this issue from MS. Scroll to the top to read the article, then read the comments, if you wish:

http://arstechnica.com/microsoft/news/2010/06/microsoft-explains-mystery-firefox-extension-fixes-update-1.ars?comments=1#comments-bar

more options

OP here again.

I don't even have a Microsoft folder in either Program Files or Program Files (x86). Uninstalling KB982381 worked until I restarted Firefox the second time.

This is unbelievably annoying.

more options

To TXGuy: No, I didn't delete any "firefoxextension" folder. In "C:\Program Files (x86)\Microsoft\Search Enhancement Pack" there is only a folder called "\Choice Guard". In this last one, there is an exe called "CGuard.exe" and a dll "ChoiceGuard.dll", althoug they both have the "last modified" voice set at almost 1 year ago. Oh, in "C:\Program Files\" there is no "\Microsoft\" folder at all. After uninstalling KB982381 I had to reboot.

more options

something else is going on here for some of us.

I don't have the folder on my system, and the problem started a day BEFORE I installed the update in question.

However, my symptom is the same as everyone else, and it seems to come and go as to when it happens.

more options

I HATE BING MORE NOW THAN BEFORE!!!!

Please someone have to help me! I need to fix it!!!

more options

One of the links that I posted Thu 10 of Jun, 2010 09:30 PST above has changed:

Link no longer works: http://forums.mozillazine.org/viewtopic.php?f=38&t=1918559

New location of that thread: http://forums.mozillazine.org/viewtopic.php?f=38&t=1920563

~~red:We can only post what we know at this time. It appears MS KB982381 caused this problem for most of the complaining users. If your problem with Bing started before 06/08/2010 please post a new question.~~

more options

I have also had the same problem, single word searches from the address bar directs me to bing, even though i have set the keyword.url to google, and enabled to true. Multiple words searches however seem to be fine. I don't have the "search helper" directory, but i do have a "Microsoft\Search Enhancement Pack\Choice Guard".

I have tried to uninstall MS update KB982381, with no success to fixing the problem.

more options

QUOTE

I don't have the "search helper" directory, but i do have a "Microsoft\Search Enhancement Pack\Choice Guard".

I have tried to uninstall MS update KB982381, with no success to fixing the problem.

/QUOTE

Exactly the same here.

more options

same exact problem discovered yesterday. tried everything the online forums said. also don't have a microsoft folder and therefore no search enhancement folder.

really annoyed about this whole situation. already uninstalled firefox and am using chrome.

more options

I have the same problem, installed the ms update but it didnt give me a new toolbar or anything. one word searches get directed to bing. i uninstalled the update and for one session on firefox everything was normal, but after that it went to bing.

It appears that this is an issue with dns hijacking. I am now using an extension that I needed when I was with bell, now I'm with rogers and apparently I need it again. It's called "NoRedirect." install it then make a new regexp pattern "http://www.bing.com/search?" and ONLY click/check "dns error", not "allow" or "source". the interface (to me) was a bit scary, because the other websites were typed in an odd manner, but just do it this way, worked for me and was easy. any questions just ask. hope this helps...

more options

Removing KB982381 fixed the problem for me, and it is fixed beyond the first FF restart. I also have no MS toolbars installed (but I did have an Ask toolbar from Foxit; uninstalled it after removing the KB update), and I have no "Microsoft" folder anywhere on my C drive; I'm using Win7 x64 Ultimate.

The coding for this change has to be somewhere in that update. If uninstalling it doesn't fix it, it must be hanging around the system somewhere, possibly in some Windows DLL. Anyone tried a System Restore?

...And they have the nerve to list it as a "Security" update! Just whose security is it protecting!? We should request inclusion of this update as spyware in virus scanner definitions--that would get their attention!

more options

The problem seems to be gone for me, at least for the time being. I'm sure I did a full reboot after removing the update but only now has anything changed. Hmmm.

more options


QUOTE

I don't have the "search helper" directory, but i do have a "Microsoft\Search Enhancement Pack\Choice Guard".

I have tried to uninstall MS update KB982381, with no success to fixing the problem.

/QUOTE

The same here.

more options

I couldn't find the suggested files from the Program Files folder either. However, with a bit of searching (a simple Windows searh for "bing") I did find something.

The search results for "bing" were all something like "C:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies\Low"

After clicking my way through into the Windows folder there was a folder called "IECompatCache" within which that (hidden) folder "Low" could be found. Even though it stated itself being empty I still gave it a try and deleted the whole "IECompatCache" folder. Strangely enough, worked for me. Either that or then the problem had mysteriously vanished over night.

more options

deleting the contents of C:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies\Low worked for me somebody at mozilla should realy sue microsoft.

  1. 1
  2. 2
  3. 3
  4. 4