Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Disable Master password pop up

  • 11 freagra
  • 89 leis an bhfadhb seo
  • 12042 views
  • Freagra is déanaí ó bolandpc

more options

Hi, This has always been an issue with FF. I share my PC. My partner has a Master Password. I do not. However every time I use Firefox I am asked for the master password, and this is repeated (over and over) every time I open a tab for a site on which he has a password set. I have my own accounts and know my passwords. I do not want a Master Password and do not want to access his accounts. How can I cancel the MP request and simply use firefox withouth being face with that annoying MP pop-up every few minutes!! Its driving me nuts. Please save me. Thanks

This happened

Every time Firefox opened

== forever

Réiteach roghnaithe

The only way to prevent the Master Password pop-up if you both (all) use the same profile is to disable the password manager temporarily. Tools > Options > Security: Passwords: "Remember passwords for sites" --- You should create a separate profile for each of you.

See: http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows http://kb.mozillazine.org/Shortcut_to_a_specific_profile ("Desktop shortcut") --- If you need to have more than one profile open at the same time then start subsequent instances with the -no-remote command line switch. You can send links from other programs to a Firefox instance that is started with -no-remote, you need to drag links in a Firefox window in such cases.

See http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

Read this answer in context 👍 1

All Replies (11)

more options

You can not disable it but you can add exceptions by going to Tools--Options--Security--Exceptions

Thanks, Moses Firefox Support

more options

Are you using the same Firefox profile?

See http://kb.mozillazine.org/Profile_Manager

more options

This has been annoying me for years, but recently it's gotten much worse, with foreign widgets on web pages containing hidden login fields, and with some extensions also requiring the master password at startup. When I open a collection of bookmarks in the browser, about half of them trigger a master password prompt, because I have login data stored for some widget on the page. All those master password prompts pile up on top of each other, and I have to dismiss them before I can do anything else. Adding exceptions is not an option because I don't even get a hint which domain triggers the prompt. Also, I still want to store login data for those sites. I just don't want to be prompted every frigging time I visit the site. Mozilla should fix this as soon as possible. At least make it nonmodal.

more options

Hello sandy,

Please start a new thread so we may see your useragent, addons, and additional information about your problem.

Thanks, Moses Firefox Support

more options

Exceptions do not seem to be the answer to this s issue

Profiles done seem to fully resolve the issue either.

My partner and I sometimes both use the PC at the same time and so both need access to Firefox at the same time. 

And she wants to access her accounts and I want to access mine. How is this possible?

Can we have more than 1 profile open at 1 time?

NB She doesnt necessarily have to use a master password at all. Although I do
more options

Réiteach Roghnaithe

The only way to prevent the Master Password pop-up if you both (all) use the same profile is to disable the password manager temporarily. Tools > Options > Security: Passwords: "Remember passwords for sites" --- You should create a separate profile for each of you.

See: http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows http://kb.mozillazine.org/Shortcut_to_a_specific_profile ("Desktop shortcut") --- If you need to have more than one profile open at the same time then start subsequent instances with the -no-remote command line switch. You can send links from other programs to a Firefox instance that is started with -no-remote, you need to drag links in a Firefox window in such cases.

See http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

more options

that's great, thx corel. This appears to have resolved the issue!

One more question, If I create several instances (and desktop shortcuts for those) does that mean that I always have to open the default firefox b4 opening any other instance? Or can I open them in any order? eg open my partners instance only. I seem to be able to but was under the impression that I shouldnt...

NB for those who wish u can also change your firefox icons to differentiate the shortcuts. There are many websites dedicated to icons. I believe Mozilla icons are generally stored at: %ProgramFiles%\Mozilla Firefox\firefox.exe

more options

If the others instances (profiles) are opened with the -no-remote switch then you can always open one instance without that switch. You can only open one instance without the -no-remote switch, all other instances (profiles) will require that switch. The order doesn't matter.

more options

Since yesterday, when I open an htm file or just click the Firfox button, Firefox won't open but shows masterpassword window for the security device. It then opens up with the home-page I set (iGoogle) shifted to the left. When I reload all seems to be OK. I cannot figure out what I changed for this to happen, neither how to make Firefox open up without asking the password and have the page display correctly the first time.

Christiaan

more options

"Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
"Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

more options

I've found out what I changed: I use Reminder Fox and I've set the Options>Network >ftp to upload a file to my website so I can sync with my Laptop. Apparently this has caused the problem, because once I removed the website again (and the various elements like Username etc go grey) the problem has disappeared.

Any suggestion as to how to use the ReminderFox option to sync and not being hampered by the password-at-startup/distorted screen?