Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox is slow to open, sometimes random links don't work, sometimes the back button doesn't work, and other assorted ridiculousness.

  • 2 fhreagra
  • 44 leis an bhfadhb seo
  • 11 views
  • Freagra is déanaí ó flabdablet

more options

Out of nowhere, Firefox started taking forever to open... sometimes as much as 45 seconds - 1 minute. Frequently it will suddenly not respond to links on a certain page, often involving desirable pop-ups that have worked in the past. If I click multiple times, sometimes I am later (more than 5 minutes) besieged by multiple pop-ups, although they rarely display correctly. Sometimes the back button won't work. If I quit Firefox, it sometimes takes forever to close, or the window will close, but the app will still be open. I've tried disabling add-ons, and opening in safe mode, etc. Any ideas? Thanks for your help.

This happened

Every time Firefox opened

== It felt like it.

Out of nowhere, Firefox started taking forever to open... sometimes as much as 45 seconds - 1 minute. Frequently it will suddenly not respond to links on a certain page, often involving desirable pop-ups that have worked in the past. If I click multiple times, sometimes I am later (more than 5 minutes) besieged by multiple pop-ups, although they rarely display correctly. Sometimes the back button won't work. If I quit Firefox, it sometimes takes forever to close, or the window will close, but the app will still be open. I've tried disabling add-ons, and opening in safe mode, etc. Any ideas? Thanks for your help. == This happened == Every time Firefox opened == It felt like it.

All Replies (2)

more options

I've got exactly the same problem with Firefox 3.6.3 after upgrade to Ubuntu 10.04. Cleaning ~/.mozilla and creating it from scratch did fix it.

more options

Do either of you have the Zotero extension installed? If so, what happens if you use Tools->Add-ons to disable it? I'm seeing this behavior on a fleet of school computers and it goes away when I turn off Zotero.