X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox will not access internet in Ubuntu 9.10 or 10.04

Postáilte

Installed Ubuntu 9.10 and 10.04. Firfeox will not access internet. Works fine in 9.04

This happened

Every time Firefox opened

Installed Ubuntu 9.10 and 10.04. Firfeox will not access internet. Works fine in 9.04 == This happened == Every time Firefox opened

Réiteach roghnaithe

SOLVED!

It turned out in my case to be an IPv6 issue.


in etc/systl.conf

all I had to do was add these lines



net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1



If you have problems editing the file

simply open Nautilus as root


sudo nautilus


btw: I commented out the notes but this site would not allow me to post the pound sign

Read this answer in context 2

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • -The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.
  • The demo print plugin for unix.
  • Shockwave Flash 10.0 r45
  • DivX Web Player version 1.4.0.233
  • The Totem 2.26.1 plugin handles video and audio streams.

Feidhmchlár

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.19) Gecko/2010040116 Ubuntu/9.04 (jaunty) Firefox/3.0.19

Tuilleadh Eolais

zzxc 22 réiteach 242 freagra

Hi - which exact problem do you have connecting? Is Ubuntu recognizing your network at all?

If you aren't sure if Ubuntu is connected at all, try running the Ubuntu Update utility in System->Administration. If Ubuntu won't connect at all, you will need to troubleshoot your network connection. If this works, and Firefox doesn't, then you need to check proxy and offline-mode setting in Firefox. To do this:

  1. Open the File menu and verify that Work Offline is not checked. (If it is checked, uncheck it)
  2. Open Edit->Preferences and click the Advanced panel. From there, click the Network tab and press the Settings... button. Make sure No Proxy is selected.
Hi - which exact problem do you have connecting? Is Ubuntu recognizing your network at all? If you aren't sure if Ubuntu is connected at all, try running the Ubuntu Update utility in System->Administration. If Ubuntu won't connect at all, you will need to troubleshoot your network connection. If this works, and Firefox doesn't, then you need to check proxy and offline-mode setting in Firefox. To do this: # Open the File menu and verify that ''Work Offline'' is not checked. (If it is checked, uncheck it) # Open Edit->Preferences and click the '''Advanced''' panel. From there, click the '''Network''' tab and press the '''Settings...''' button. Make sure ''No Proxy'' is selected.

Úinéir na ceiste

Did this - no change I am afraid. Also checked the 'ping' option - that gave 100% success.

I only get this problem with Ubuntu 9.10 and 10.04 - as I said before, Ubuntu 9.04 is perfect in this respect- why is the diffrence?

Did this - no change I am afraid. Also checked the 'ping' option - that gave 100% success. I only get this problem with Ubuntu 9.10 and 10.04 - as I said before, Ubuntu 9.04 is perfect in this respect- why is the diffrence?
zzxc 22 réiteach 242 freagra

Was "No Proxy" selected? And does going to http://74.125.19.147 work?

If you're still getting connection errors, paste me the output of these commands:

  • route -n
  • ifconfig
  • netstat -na
Was "No Proxy" selected? And does going to http://74.125.19.147 work? If you're still getting connection errors, paste me the output of these commands: * '''route -n''' * '''ifconfig''' * '''netstat -na'''

Freagra Cabhrach

Hi I have the same problem, and yes it works with ip address you gave however, it does not access the same with google.com typed in the address bar

Thanks.

Hi I have the same problem, and yes it works with ip address you gave however, it does not access the same with google.com typed in the address bar Thanks.

Úinéir na ceiste

I've had this issue before. Changing the settings to "No Proxy" worked once, but it hasn't worked so far. It will, however, be able to go to the ubuntu website and xkcd.

I've had this issue before. Changing the settings to "No Proxy" worked once, but it hasn't worked so far. It ''will'', however, be able to go to the ubuntu website and xkcd.

Úinéir na ceiste

Same problem. ping works, firefox and email (thunderbird) do not. I can access google using the numerical ip address. This sounds like a dns issue. How do we fix this?

Same problem. ping works, firefox and email (thunderbird) do not. I can access google using the numerical ip address. This sounds like a dns issue. How do we fix this?

Úinéir na ceiste

Same problem. My firefox and thunderbird work only under sudo. I have two identical machines, one has ubuntu 10.04 the other ubuntu 10.04 + win7. The problem appears in the second. Both has clean ubuntus installations, moreover, the ./mozilla and ./thunderbird folders in my user directory come from ubuntu 9.10 (they were backed up and copied by hand in the new 10.04). All other connections work fine (synaptic, ping ...)

Same problem. My firefox and thunderbird work only under sudo. I have two identical machines, one has ubuntu 10.04 the other ubuntu 10.04 + win7. The problem appears in the second. Both has clean ubuntus installations, moreover, the ./mozilla and ./thunderbird folders in my user directory come from ubuntu 9.10 (they were backed up and copied by hand in the new 10.04). All other connections work fine (synaptic, ping ...)

Úinéir na ceiste

Firefox will only work on google, oddly enough. If I try to open any other website, it doesn't work.

Firefox will only work on google, oddly enough. If I try to open any other website, it doesn't work.

Úinéir na ceiste

I have a very similar problem. All was working perfectly in Ubuntu 9.04 but with 9.10 and 10.04

  • all* Mozilla products lose connectivity if I reboot my DSL modem. All other browsers such as

Google Chrome and Opera conenct with no problem at all. By making *no* changes to my system, Firefox and Thunderbird little by little start working again and within 2 - 8 hours return to normal

This I consider a major problem!

I have a very similar problem. All was working perfectly in Ubuntu 9.04 but with 9.10 and 10.04 *all* Mozilla products lose connectivity if I reboot my DSL modem. All other browsers such as Google Chrome and Opera conenct with no problem at all. By making *no* changes to my system, Firefox and Thunderbird little by little start working again and within 2 - 8 hours return to normal This I consider a major problem!

Úinéir na ceiste

I am a Linux newbie and just installed Ubuntu 10.04 in my new desktop. I find that Chromium, Ubuntu updates are able to connect to internet fine and ping returns 100% success but Firefox just doesn't load anything - I keep getting a Page takes too long to load error message. Any help or guidance will be helpful.

I am a Linux newbie and just installed Ubuntu 10.04 in my new desktop. I find that Chromium, Ubuntu updates are able to connect to internet fine and ping returns 100% success but Firefox just doesn't load anything - I keep getting a Page takes too long to load error message. Any help or guidance will be helpful.

Réiteach Roghnaithe

SOLVED!

It turned out in my case to be an IPv6 issue.


in etc/systl.conf

all I had to do was add these lines



net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1



If you have problems editing the file

simply open Nautilus as root


sudo nautilus


btw: I commented out the notes but this site would not allow me to post the pound sign

SOLVED! It turned out in my case to be an IPv6 issue. in etc/systl.conf all I had to do was add these lines net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 If you have problems editing the file simply open Nautilus as root sudo nautilus btw: I commented out the notes but this site would not allow me to post the pound sign
krash18 0 réiteach 3 freagra

It turned out in my case to be an IPv6 issue.


in etc/systl.conf

all I had to do was add these lines


net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1


If you have problems editing the file

simply open Nautilus as root


sudo nautilus


btw: I commented out the notes but this site would not allow me to post the pound sign


Please in English I can understand, What are you talking about? I would like to fix my machine as well but I don't know what your talking about.

It turned out in my case to be an IPv6 issue. in etc/systl.conf all I had to do was add these lines net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 If you have problems editing the file simply open Nautilus as root sudo nautilus btw: I commented out the notes but this site would not allow me to post the pound sign Please in English I can understand, What are you talking about? I would like to fix my machine as well but I don't know what your talking about.
sreeraj70 0 réiteach 1 freagra

Freagra Cabhrach

The following works for me....... Open your Firefox and type about:config at URL address bar and hit enter. U will get a list of lines. Search for the lines given below( simply copy & paste in search bar. Eg-paste'network.http.pipelining'). Make the following changes. To make a False into True, select the line to change, and double click. On the 2nd option change, right click and select Modify

- network.http.pipelining > Make it True

- network.http.pipelining.maxrequests > Make it 8 or 10

- network.http.proxy.pipelining > Make it True

- network.dns.disableIPv6 > Make it True

I hope this helps for some users

The following works for me....... Open your Firefox and type about:config at URL address bar and hit enter. U will get a list of lines. Search for the lines given below( simply copy & paste in search bar. Eg-paste'network.http.pipelining'). Make the following changes. To make a False into True, select the line to change, and double click. On the 2nd option change, right click and select Modify - network.http.pipelining > Make it True - network.http.pipelining.maxrequests > Make it 8 or 10 - network.http.proxy.pipelining > Make it True - network.dns.disableIPv6 > Make it True I hope this helps for some users
eusetep 0 réiteach 1 freagra

Well done! Worked for me when all else failed. How would a newbie be able to work that out!

Well done! Worked for me when all else failed. How would a newbie be able to work that out!
Albinab 0 réiteach 2 freagra

Had a similar problem, and was really puzzled by it because Chrome worked just fine. Because I had it right from beginning, suspected that firefox package was corrupted, and in seeming agreement with that when I did "complete removal" and reinstall from Synaptic, it worked. Unfortunately that had to be repeated after each restart, so I found this page. Worked for Firefox instantly, still sorting out Thunderbird. Thanks for the info!

Had a similar problem, and was really puzzled by it because Chrome worked just fine. Because I had it right from beginning, suspected that firefox package was corrupted, and in seeming agreement with that when I did "complete removal" and reinstall from Synaptic, it worked. Unfortunately that had to be repeated after each restart, so I found this page. Worked for Firefox instantly, still sorting out Thunderbird. Thanks for the info!
Albinab 0 réiteach 2 freagra

Update: after locating config file for Thunderbird, it works too! Thanks a bunch.

Update: after locating config file for Thunderbird, it works too! Thanks a bunch.
landiatico 0 réiteach 1 freagra

I had the same problem after upgrading to FF 11 on ubuntu 10.10, the problem was caused by the ubuntuOne bookmark sync plugin xul-ext-bindwood, after doing a sudo apt-get remove xul-ext-bindwood the problem was fixed

bug 958304 was opened in Launchpad in order to fix blindwood: https://bugs.launchpad.net/ubuntu/+source/bindwood/+bug/958304

More info

I had the same problem after upgrading to FF 11 on ubuntu 10.10, the problem was caused by the ubuntuOne bookmark sync plugin xul-ext-bindwood, after doing a '''sudo apt-get remove xul-ext-bindwood''' the problem was fixed bug [https://bugs.launchpad.net/ubuntu/+source/bindwood/+bug/958304 958304] was opened in Launchpad in order to fix blindwood: https://bugs.launchpad.net/ubuntu/+source/bindwood/+bug/958304 [http://ubuntuforums.org/showthread.php?t=1941792&page=2 More info]

Athraithe ag landiatico ar