Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

I'm getting a popup blocked on a page I need to have the popup working

  • 23 freagra
  • 2 leis an bhfadhb seo
  • 79 views
  • Freagra is déanaí ó Christopher

more options

I have turned off all extensions, allowed all permissions on the page, changed the Privacy to Standard, turned off enhanced protection, but I still cannot get the popup to show on this page (need login to see actual page)

https://app.gohighlevel.com/location/ApwnvXGFIEHm8LKgmFQz/page-builder/hKQsgETZFHVjwGxTUCeN

I cannot find anything else which can be blocking it, but something is.

If I load the page in Edge, it works fine.

I have turned off all extensions, allowed all permissions on the page, changed the Privacy to Standard, turned off enhanced protection, but I still cannot get the popup to show on this page (need login to see actual page) https://app.gohighlevel.com/location/ApwnvXGFIEHm8LKgmFQz/page-builder/hKQsgETZFHVjwGxTUCeN I cannot find anything else which can be blocking it, but something is. If I load the page in Edge, it works fine.

All Replies (20)

more options

You sure your security software isn't causing this as well?

more options

I'm not sure what security software you might suspect.

Firefox does not work properly, Edge works properly.

I have restarted Firefox in Troubleshooting mode, to disable all plugins, and the issue persists.

I still have Enhanced Tracking Protection disabled for this site/page.

I have permissions for the page all enabled, including Send Notifications and Autoplay for both audio and video.

I have Privacy & Security set to Standard.

I have reviewed all security and privacy settings I can find, enabled everything I can find, and the popup does not work in Firefox, and works without doing anything special in Edge.

more options

You could try this. While on the site, open the Page Info window (using ctl+i) and, on the permissions tab, change Open pop-up windows to Allow.

https://support.mozilla.org/en-US/kb/firefox-page-info-window

more options

It is already allowed on that page

more options
more options

Do you see any kind of indication that a popup has been blocked? Try allowing popups globally by unticking "Block pop-up windows" in settings.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

Terry said

Check for errors in the web console. https://firefox-source-docs.mozilla.org/devtools-user/web_console/

No errors that I can see. Image of console attached.

more options

zeroknight said

Do you see any kind of indication that a popup has been blocked? Try allowing popups globally by unticking "Block pop-up windows" in settings. Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

No indication a popup was blocked. I have allowed popups globally and in every place i can find to allow them.

I installed the Developer Edition and tried there without changing anything from stock and see the same results. Image of that console log also attached.

more options

Is that actually a pop-up or merely an overlay on the webpage.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

more options

cor-el said

Is that actually a pop-up or merely an overlay on the webpage. You can try these steps in case of issues with webpages: You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings). "Remove the Cookies" for websites that cause problems:
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"
"Clear the Cache":
  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear
Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.
  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.
  • click the shield icon for more detail and possibly disable the protection
You can check the Web Console for relevant-looking messages like blocked content.

It's probably an overlay, image attached.

Shift-reload doesn't help.

restarting Firefox in Troubleshooting mode doesn't help

downloading, installing and trying on bone stock Developer Edition does not help.

I have disabled Advance Tracking Protection for this whole site, it does not help.

I have allowed popups everywhere I can find, and it does not help.

more options

Does it work if you install User Agent Switcher and set it to Chrome?

more options

What do you get if you right-click in the overlay and check this in the Inspector? Is that an iframe ?

more options

cor-el said

What do you get if you right-click in the overlay and check this in the Inspector? Is that an iframe ?

I'm not really sure. The page you linked isn't super easy to follow. I've attached the console I get when I inspect this element. If this isn't the right thing, or you'd like to see more, please just let me know.

more options

zeroknight said

Does it work if you install User Agent Switcher and set it to Chrome?

That does not seem to work. I tried a couple different Chrome versions, but nothing change the behavior, it still doesn't open the popup.

i do not have chrome installed on this computer, so i'm not sure if that prevents this plugin from working. I don't really want to install Chrome, so if that's a requirement, I would be willing to test if that leads to another solution, but i wouldn't consider that a long-term solution.

i really believe this should just work properly in Firefox without having to install band-aids.

more options

You have already tested in Edge so there is no need to test in Chrome.

Does it work with Firefox 115 ESR?

more options

That content looks rather deeply nested, I don't know if that could be part of the problem.

more options

zeroknight said

You have already tested in Edge so there is no need to test in Chrome. Does it work with Firefox 115 ESR?

It does not work with 115 ESR.

more options

cor-el said

That content looks rather deeply nested, I don't know if that could be part of the problem.

any suggestions on next steps for me to get this working?

more options

You can test older versions of Firefox with mozregression to see if it ever worked in the past and if so, on what day it stopped working.

more options

zeroknight said

You can test older versions of Firefox with mozregression to see if it ever worked in the past and if so, on what day it stopped working.

thanks again.

While that would be interesting to know, I need it working in the current version.

Is there any way to get help directly from Mozilla on this?

  1. 1
  2. 2