Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox saves files that I only wanted to open

  • 4 fhreagra
  • 2 leis an bhfadhb seo
  • 108 views
  • Freagra is déanaí ó gsm600

more options

Firefox saves files that I only wanted to open with another application.

I checked the previous solutions in the forum, but they did not work for me. (Windows 11) I changed in system> general > download , applications > the app to open that file type and it works, but besides this Firefox keeps saving the files in the default download folder.

I tried also about:config browser.download.improvements_to_download_panel to false. browser.download.start_downloads_in_tmp_dir change to true No change - still saving copies.

Firefox saves files that I only wanted to open with another application. I checked the previous solutions in the forum, but they did not work for me. (Windows 11) I changed in system> general > download , applications > the app to open that file type and it works, but besides this Firefox keeps saving the files in the default download folder. I tried also about:config browser.download.improvements_to_download_panel to false. browser.download.start_downloads_in_tmp_dir change to true No change - still saving copies.

Réiteach roghnaithe

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
Read this answer in context 👍 1

All Replies (4)

more options

Firefox needs to download and save a file to be able to view this file in a tab or pass it to another application. Current Firefox versions save the file to the default Downloads folder that you can override via browser.download.start_downloads_in_tmp_dir = true to save the file to the temp folder.

more options

Thanks for the reply but you did not read my post - this doesn't work for me.

more options

Réiteach Roghnaithe

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Followed the instructions "3-bar" menu >Help > Troubleshoot Mode>-> Add-ons -> Themes Visionary — Balanced > disable > restart the browser > Problem solved!

Thanks a lot!