Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video does not play audio when I try to watch videos through duck duck go

more options

I have tried watching videos through chrome and other browsers by searching something via duck duck go and watching that video on duck duck go, and it works on other browser so it must be specific to firefox.

Whenever I try to watch a video, in the drop down bar firefox select to mute audio for some reason. I then select 'allow audio and video' and refresh the page but the video is still muted for some reason. This also happens when I try to use other video sites. This has only started to happen recently in the past two days (and yes I am updated to the latest version of firefox).

I have tried watching videos through chrome and other browsers by searching something via duck duck go and watching that video on duck duck go, and it works on other browser so it must be specific to firefox. Whenever I try to watch a video, in the drop down bar firefox select to mute audio for some reason. I then select 'allow audio and video' and refresh the page but the video is still muted for some reason. This also happens when I try to use other video sites. This has only started to happen recently in the past two days (and yes I am updated to the latest version of firefox).

Réiteach roghnaithe

Try disabling cold turkey blocker.

Read this answer in context 👍 1

All Replies (12)

more options

URL of the link would help others verify if this is duckduckgo issue or browser issue.

Helpful?

more options

Helpful?

more options

Sound is muted initially here as well, possibly because of some setting or preference. It's sufficient to click that icon to 'unmute' sound. Refreshing the page would negate that action.

Athraithe ag Terry ar

Helpful?

more options

Have tried to refresh it but still doesn't work. Any ideas on what preferences might be responsible?

Helpful?

more options

Perhaps my reply wasn't clear. Refreshing the page would negate the action of 'unmuting' sound.

You could use the page info window. When on the site, ctl+i > Permissions tab : Autoplay - Allow Audio and Video.

What values do you have for these preferences? media.autoplay.default media.autoplay.block-event.enabled media.block-autoplay-until-in-foreground media.autoplay.allow-extension-background-pages media.autoplay.blocking_policy

Helpful?

more options

Hi Terry, to clarify even when I did select the allow audio and video option without refreshing it still didn't work. I went into permissions and it was selected to block audio by default. I since went into settings and firefox and changed it to allow audio by default. However there is still no audio.

regarding the latter part of your comment about the list of values, I'm not quite sure what they relate to or where to check for them in firefox.

Helpful?

more options

Helpful?

more options

just checked about:config and this is what I got.

media.autoplay.default true

media.autoplay.block-event.enabled false

media.block-autoplay-until-in-foreground true

media.autoplay.allow-extension-background-pages true

media.autoplay.blocking_policy 0

Helpful?

more options

Helpful?

more options

Just tried trouble shooting, thing is I have cold turkey blocker installed so it automatically closes it since it thinks i'm trying to get around the extension.

Just did a refresh. Only thing that changed was that the default auto play option for media across websites reverted to blocking audio. I changed it again in settings to allow audio by default but still no sound.

Helpful?

more options

Réiteach Roghnaithe

Try disabling cold turkey blocker.

Helpful?

more options

Dear God I am an absolute idiot. I had firefox muted in volume mixer. Probably would have found it easier if I wasn't using windows 10 to be honest. Really should either downgrade back to good old windows 7 or download Linux.

That being said though thanks for your help.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.