Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox somehow took 4-11 second to actually connect to new address, even the sites I regularly visits. after I'm updating to Windows 11.

  • 1 freagra
  • 1 leis an bhfadhb seo
  • 2 views
  • Freagra is déanaí ó Mich

more options

So I I've been holding out upgrading to W11 for some time now, but have to upgrade after being tipped by a friend about ONE convenient feature for multitasking, split apps view and combining it into one tab. So far so good, didn't experience any issue. One complain I have is the gigantic cut, copy, open..etc Tab at the top of the new file explorer. But, again, nothing out of the ordinary.

But when I opened Firefox for the first time after upgrading I noticed a painful delay before actually loading the new pages. At first I thought it was only because I just recently updated the OS, so I leave for few hours and keep working my docs. After going back to browse I still have the same issue. This time I notably irritated because of browsing my regularly checked websites have so much delay now compared to before I upgrade to W11.

Here's the list of thing I tried to fix this issue.

   Clearing caches
   Disabling add ons
   Disable enhanced protection
   Refresh Firefox program
   Updating my chipset driver 
   updating my gfx driver
   Reseting my network.

Nothing I tried above worked.

Again the issue is not internet speed. When I downloaded the AMD drivers, it was 14MBps, quite fast.

Then I open the "task manager" and tick the "always on top" option. I noticed that Firefox is still idling even after I clicked links in my homepage. Firefox only uses 2% of CPU usage. It stays that way for 4-11 seconds (depending on the websites I tested) before eventually ramps up the CPU usage to the percentage I expected to opens a new website.

Anyone knows the answer? Please I'm getting desperate here. I don't want to daily drive chromium forks and would like to keep using Firefox.

Asus vivobook laptop, Ryzen 5 3500u, 16gb 2666mhz ram

So I I've been holding out upgrading to W11 for some time now, but have to upgrade after being tipped by a friend about ONE convenient feature for multitasking, split apps view and combining it into one tab. So far so good, didn't experience any issue. One complain I have is the gigantic cut, copy, open..etc Tab at the top of the new file explorer. But, again, nothing out of the ordinary. But when I opened Firefox for the first time after upgrading I noticed a painful delay before actually loading the new pages. At first I thought it was only because I just recently updated the OS, so I leave for few hours and keep working my docs. After going back to browse I still have the same issue. This time I notably irritated because of browsing my regularly checked websites have so much delay now compared to before I upgrade to W11. Here's the list of thing I tried to fix this issue. Clearing caches Disabling add ons Disable enhanced protection Refresh Firefox program Updating my chipset driver updating my gfx driver Reseting my network. Nothing I tried above worked. Again the issue is not internet speed. When I downloaded the AMD drivers, it was 14MBps, quite fast. Then I open the "task manager" and tick the "always on top" option. I noticed that Firefox is still idling even after I clicked links in my homepage. Firefox only uses 2% of CPU usage. It stays that way for 4-11 seconds (depending on the websites I tested) before eventually ramps up the CPU usage to the percentage I expected to opens a new website. Anyone knows the answer? Please I'm getting desperate here. I don't want to daily drive chromium forks and would like to keep using Firefox. Asus vivobook laptop, Ryzen 5 3500u, 16gb 2666mhz ram

All Replies (1)

more options

The following are a few things you can try to resolve the issue:

1)Clear your Firefox cache and cookies. Go to the "History" menu and select "Clear Recent History." Make sure to select "Cookies" and "Cache" and click "Clear Now." 2)Disable any unnecessary extensions or add-ons. Go to "Add-ons" in the Firefox menu and disable or remove any extensions that you don't use or that might be causing the issue. 3)Disable hardware acceleration. Go to "Options" in the Firefox menu, and in the "General" tab, uncheck the box next to "Use hardware acceleration when available." 4)Disable IPv6. Go to "about:config" in Firefox, search for "network.dns.disableIPv6", and set its value to "true". 5)Reset Firefox to its default settings. Go to "Help" in the Firefox menu, and select "Troubleshoot Firefox." Click on "Refresh Firefox" and confirm the action.