Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Space characters incorrect; button pointing to URL ending in hash (#) not working

  • 2 fhreagra
  • 0 leis an bhfadhb seo
  • 14 views
  • Freagra is déanaí ó MrDobbalina

more options

I am having issues with pages on DAX Guide, e.g.: https://dax.guide/now/

These issues are when using Firefox on Windows 10. I have tried with Safe mode, and turning off Enhanced Tracking protection. I have made no changes to Javascript etc.

Issue 1 If I select a code example and try to run it in an external program (e.g. DAX Studio), it fails, and I have found that the reason is because the "space" characters are not ASCII code 32, which is a normal space, but instead ASCII 160. Another symptom of this is that you cannot unindent the paragraphs in a text editor (Vim), if you paste the code there. I have tested and this is not an issue with Chrome, Edge, or Opera. Also if I click on the "Try It" button, it takes you to a runnable version of the code where the spaces are correct. These are workarounds, but why is Firefox using the wrong space characters?

Issue 2 I have seen another response to this kind of question, but it did not exactly answer it: on the website as above, when you click on the "Copy" button, which points to https://dax.guide/now/#, the code is supposed to be copied to the clipboard, however it does nothing. This works without issue in the browsers mentioned above. I have noticed previously on other websites that URLs ending in hash / pound did not work in Firefox. Is this something that Firefox just does not handle, or is there a setting to enable it?

Thanks

I am having issues with pages on DAX Guide, e.g.: [https://dax.guide/now/ https://dax.guide/now/] These issues are when using Firefox on Windows 10. I have tried with Safe mode, and turning off Enhanced Tracking protection. I have made no changes to Javascript etc. '''Issue 1''' If I select a code example and try to run it in an external program (e.g. DAX Studio), it fails, and I have found that the reason is because the "space" characters are not ASCII code 32, which is a normal space, but instead ASCII 160. Another symptom of this is that you cannot unindent the paragraphs in a text editor (Vim), if you paste the code there. I have tested and this is not an issue with Chrome, Edge, or Opera. Also if I click on the "Try It" button, it takes you to a runnable version of the code where the spaces are correct. These are workarounds, but why is Firefox using the wrong space characters? '''Issue 2''' I have seen another response to this kind of question, but it did not exactly answer it: on the website as above, when you click on the "Copy" button, which points to https://dax.guide/now/#, the code is supposed to be copied to the clipboard, however it does nothing. This works without issue in the browsers mentioned above. I have noticed previously on other websites that URLs ending in hash / pound did not work in Firefox. Is this something that Firefox just does not handle, or is there a setting to enable it? Thanks

Athraithe ag MrDobbalina ar

Réiteach roghnaithe

Firefox usually doesn't allow access to the clipboard via JavaScript. Try keyboard shortcuts in case the buttons on the webpage or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command+C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command+V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command+X)

Those 160 characters are non-breaking spaces (U+00A0;  ). There is a mention about this in the Firefox 107 release notes under Unresolved.

In order to better support certain typographical conventions, Firefox now preserves some non-breaking spaces when copying text to the clipboard instead of changing them to regular spaces. The new behavior is known to cause problems when non-breaking spaces are used for indentation.

  • 1769534 - Preserve non-breaking spaces when copying HTML content [107]
  • 1801186 - On copy, non-breaking spaces used for padding should be converted to regular spaces

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (2)

more options

Réiteach Roghnaithe

Firefox usually doesn't allow access to the clipboard via JavaScript. Try keyboard shortcuts in case the buttons on the webpage or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command+C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command+V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command+X)

Those 160 characters are non-breaking spaces (U+00A0;  ). There is a mention about this in the Firefox 107 release notes under Unresolved.

In order to better support certain typographical conventions, Firefox now preserves some non-breaking spaces when copying text to the clipboard instead of changing them to regular spaces. The new behavior is known to cause problems when non-breaking spaces are used for indentation.

  • 1769534 - Preserve non-breaking spaces when copying HTML content [107]
  • 1801186 - On copy, non-breaking spaces used for padding should be converted to regular spaces

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Athraithe ag cor-el ar

Helpful?

more options

Thank you very much for the fast and informative answers!

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.