Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Home page stuck on Firefox.

  • 11 freagra
  • 0 leis an bhfadhb seo
  • 210 views
  • Freagra is déanaí ó cor-el

more options

Using Firefox 106.0.4 on W10.

Hi, no matter what I try and do: Tools / Settings / Home / New Windows and Tabs - I cannot change Homepage and New Windows to either a custom URL or Blank Page?

This just started a this week - a few updates ago.

I can & have changed New Tabs using New Tab Override (using it for years)

Any help or ideas appreciated, thank you.

J

Using Firefox 106.0.4 on W10. Hi, no matter what I try and do: Tools / Settings / Home / New Windows and Tabs - I cannot change Homepage and New Windows to either a custom URL or Blank Page? This just started a this week - a few updates ago. I can & have changed New Tabs using New Tab Override (using it for years) Any help or ideas appreciated, thank you. J

Réiteach roghnaithe

Hmm, I'm puzzled. They obviously should match.

You'll notice in about:config that several of those preferences have trash cans at the right end of their rows. These are things Firefox added during normal operation and I think you could delete them (click their trash cans) and test whether that helps.

Read this answer in context 👍 1

All Replies (11)

more options

Hi Dropa,

firstly it wasn't I that gave you the thumbs down & secondly, I appreciate the prompt reply.

I've stated my settings above and as I said when I click onto Homepage and New Windows I simply cannot change it?

When I use the Home page option I get a blank screen (1st tab in screenshot).

I can and do use a custom new tab (google.ie - also what I used to use as my homepage)

At the bottom of the screenshot I've included another screenshot of what I attempt (used to work) but it fails to take?

Regards j

more options

Hi J, could you go under the covers and take a look here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. We have had this setting for a long time, so I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.startup.homepage and pause while the list is filtered -- Firefox should display 3-6 lines; we're focused on the top one

(3) If browser.startup.homepage doesn't list your preferred home page, you can try a manual edit:

Double-click the preference to display an editing field, and change the value to the full URL of the page you prefer, then press Enter or click the blue check mark button to save the change. (If you want a blank page, use about:blank as the URL.)

If this row has a lock and can't be edited, we'll need to help you investigate what is causing that.

more options

Hi jscher2000,

appreciate your time, thank you.

It is set to what I want there (see screenshot) but funnily enough when I go into settings, it is still listed: Firefox Home (default)?

Do I need to change any values on that about config page?

Again, my thanks.

j

more options

Réiteach Roghnaithe

Hmm, I'm puzzled. They obviously should match.

You'll notice in about:config that several of those preferences have trash cans at the right end of their rows. These are things Firefox added during normal operation and I think you could delete them (click their trash cans) and test whether that helps.

more options

Hi jscher2000,

good man - I clicked all the trash cans and manually typed my preferred homepage in and it's now working.

Thank you for your time and knowledge.

Regards J

more options

Now, when I close a Tab and try 'Reopen Close Tab' it will reopen that tab UNLESS I've added New Tab before doing so, in which case it'll just keep opening my New Tab custom URL & will continue to do so each time...?

Swap one problem for another - Firefox is broken...

Sigh

more options

This could be a problem with the NTO extension. You can test that by disabling this extension temporarily.

more options

Hi cor-el,

excuse the late response.

I have tried with and without NTO extension & I've tried changing settings on the NTO extension - it simply doesn't work anymore since I implemented the fix above.

There's one other new anomaly since the 'fix' and that's when I used to middle mouse click (using mouse wheel) on a Tab, it would open a new Tab. Now it closes that Tab. But, if I click on a space ahead of the last Tab, it will open a new Tab (still with a blank Firefox page).

IDK, think I'd rather suffer the first problem than the new set of problems - is there a reset?

Appreciate your time, thank you.

J

more options

It is normal behavior to close a tab with a middle-click on the tab and open a new tab with a middle-click or a double-click in empty space on the tab bar. If you want to use the New Tab Override extension to set your custom new tab page then you need to do that via the settings page of the NTO extension. Firefox will show a warning in "Settings -> Home" if an extension has control of the home and new tab page.

more options

Hi cor-el

"If you want to use the New Tab Override extension to set your custom new tab page then you need to do that via the settings page of the NTO extension." - I am aware and this is what I did to use google.ie as my New Tab Custom URL - That used to work but now does not - nor is there any reports of this problem on their review page.

I've also tried all the other settings within that extension and I've also tried Firefox settings: Ok, on searching the latter path for this comment I see it is now viable: Tools/Settings/Home/New Tabs & NTO was an option - that option was not available before.

That's great fixed.

I can live with the other changes (repoen close tab being dysfunctional and the middle wheel settings the way they are - that may be normal but it was not my experience...perhaps I changed this somehow before, IDK/cannot remember but it was a lot handier, IMO, just middle clicking on a tab to open a new one beside it)

Thank you one and all for your time, patience and diligence.

Regards J

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

You can also try to delete prefs.js in the Firefox profile folder to reset all the preferences and also uninstall and reinstall NTO.