Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

displaying newsletter sign up forms from mailerlite

  • 4 fhreagra
  • 0 leis an bhfadhb seo
  • 6 views
  • Freagra is déanaí ó cor-el

more options

I don't know the correct name for my problem. I have been trying to display an email collection form (newsletter sign-up) from Mailerlite at my website, virginiasanderson.com, on Wordpress. The form displays on my Android/Samsung phone and on Chrome, but will not display on Firefox. I spent considerable time struggling, with help from Mailerlite, before I realized the problem was Firefox. I have tried turning off Enhanced Protection. The form is an embedded form, not a pop-up, but I also allowed pop-ups for the site. I must have some other setting that is preventing these forms from working on Firefox. I much prefer Firefox to other options, but this may be a deal-breaker when it comes to continuing to build my site. Please help.

I don't know the correct name for my problem. I have been trying to display an email collection form (newsletter sign-up) from Mailerlite at my website, virginiasanderson.com, on Wordpress. The form displays on my Android/Samsung phone and on Chrome, but will not display on Firefox. I spent considerable time struggling, with help from Mailerlite, before I realized the problem was Firefox. I have tried turning off Enhanced Protection. The form is an embedded form, not a pop-up, but I also allowed pop-ups for the site. I must have some other setting that is preventing these forms from working on Firefox. I much prefer Firefox to other options, but this may be a deal-breaker when it comes to continuing to build my site. Please help.

All Replies (4)

more options

Your going to have to provide screenshot from both Chrome and Firefox for anyone to compare to see what is missing and how they are different as well as the URL of the problem sites. And how to replicate the issue.

Helpful?

more options

Do you mean this form ? If that is the case then it is working fine.


Did you check the Web Console for possible messages related to this issue ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

Yes, that's the form. Everyone can see it but me! I have looked at the Console and see messages about blocked content, but I am afraid that fixing code at this level is way beyond me. I have cleared the cache and history at least once; will do so again, trying to follow your directions, but apparently I have something set somewhere that is not allowing me to see this form. That makes it really hard to go to work on getting it in the right position, etc. I get the same result whether I am in https or http. One suggestion was to completely uninstall Firefox and re-install it. Would this make a difference? It would be really good to know what setting is causing this at my end. Thank you!!!

Helpful?

more options

Can you attach a screenshot that shows relevent messages (filter for virginiasanderson) ? Do you have content blocking extensions ?


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.