Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

bug in Secure Conection always on google sites and youtube.

  • 9 bhfreagra
  • 0 leis an bhfadhb seo
  • 10 views
  • Freagra is déanaí ó wdedf

more options

from 89338383 sites just google sites have this problem. And nothing work. is so annoying ill uninstall firefox and this browser forever. 9/10 times wana go on google or yt Secure conection preblem is making me mad its an firfox account bug not the visited site have problems.

from 89338383 sites just google sites have this problem. And nothing work. is so annoying ill uninstall firefox and this browser forever. 9/10 times wana go on google or yt Secure conection preblem is making me mad its an firfox account bug not the visited site have problems.
Attached screenshots

Réiteach roghnaithe

Now google sites look ok :). No connection errors :) Thanks you very much guys!! At least from now all is looking fine! Big Thanks!

Read this answer in context 👍 0

All Replies (9)

more options

Try clearing the web content cache and disabling Firefox from using any proxy server. Here's how:

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (only select Cached web content, don't clear all cookies and site data)

If you have a large hard drive, this might take a few minutes.

(2) Disable using any system-level proxy

Open the Settings page using either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter to load it

In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section.

Click the Settings button, select "No Proxy" near the top of the dialog, and click OK near the bottom of the dialog.

Any difference?

more options

You can try to disable DNS over HTTPS.

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

more options

Nothing worked. Also tried a lot of webpages like this one https://www.techinpost.com/how-fix-solve-secure-connection-failed-firefox-browser-error-code/ ...the problem is still there.

more options

Is it always the same code: "PR_END_OF_FILE_ERROR" ?

Any difference if you use a full URL such as

What kind of internet connection -- home service provider, work provider, public hotspot, VPN, something else?

more options

Only "google owned web suite" sites are affected. Whole Internet is working great as expected... Im not a fan of the engine, but im using gmail and cant ignore youtube. And yes, is the same error all the time. And this bug have already 4 years and... is annoying.

more options

and in this error window we dont have the option "Are you sure you want go to a insecure site? Yes/ No"

more options

So list the Addons your using as it sounds like you got other software causing google issues as that site shouldn't require the "Insecure site" yes or no to continue.

more options

Some users have been experiencing a mid-session inability to connect to Google sites. That manifests differently than your situation because there is no error page, the connection just doesn't work. But you could try this change and see whether it makes any difference: turn off the "zero round trip resumption" feature:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste security.tls.enable_0rtt_data and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

After that, try Google again in a new tab. Any improvement?


Also, just to confirm, when this problem hits in Firefox, can you visit the sites normally in Microsoft Edge or other alternate browser?

more options

Réiteach Roghnaithe

Now google sites look ok :). No connection errors :) Thanks you very much guys!! At least from now all is looking fine! Big Thanks!