Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox & Ad Blockers

  • 29 freagra
  • 2 leis an bhfadhb seo
  • 139 views
  • Freagra is déanaí ó Amelia

more options

I made a post the other week about issues I was having with Firefox & YouTube.

Having put the browser in safe mode I discovered that it was my ad blocker/s. That said, I had notice Firefox lagging or loading hard on video sites, not just YouTube as well as some applets on other sites. And having experimented with various ad blockers and video sites as well as my own blogs, I find that I am not having these problems with ad blockers in Chrome or Edge, but only Firefox, so much so, that most of these sites are entirely unusable unless I disable the ad blocker/s in Firefox.

Frankly, I've been noticing it for some time, but as of the other week they have nearly rendered the browser unusable, or the ad blocker/s unusable in Firefox on said sites. I have completely uninstalled and reinstalled the add-ons, from the Mozilla site, to no real avail.

It is not only annoying but very frustrating and I am about to give up, on the browser altogether. I am not having these problems with the same ad blocker/s in Chrome.

I've spent nearly two weeks on this and it hasn't gotten better.

There it is. Thank you.

I made a post the other week about issues I was having with Firefox & YouTube. Having put the browser in safe mode I discovered that it was my ad blocker/s. That said, I had notice Firefox lagging or loading hard on video sites, not just YouTube as well as some applets on other sites. And having experimented with various ad blockers and video sites as well as my own blogs, I find that I am not having these problems with ad blockers in Chrome or Edge, but only Firefox, so much so, that most of these sites are entirely unusable unless I disable the ad blocker/s in Firefox. Frankly, I've been noticing it for some time, but as of the other week they have nearly rendered the browser unusable, or the ad blocker/s unusable in Firefox on said sites. I have completely uninstalled and reinstalled the add-ons, from the Mozilla site, to no real avail. It is not only annoying but very frustrating and I am about to give up, on the browser altogether. I am not having these problems with the same ad blocker/s in Chrome. I've spent nearly two weeks on this and it hasn't gotten better. There it is. Thank you.

All Replies (9)

more options

@ -elison-

Thank you very much for this!

I haven't taken the time to really explore this add on yet.
more options

I just wanted to report that there has been no resolution to this problem.

I have tried everything that has been suggest and Firefox still hangs up on YouTube, some other video sites and some applets.

I have tried several of the ad blockers, and I don’t know that I can blame them except to say how they are working with the Firefox browser. For the last week, and especially most video sites like YouTube, the page simply doesn’t want to load and I get an error message saying I am offline when clearly I am not. I might blame some of this on YouTube, and yet—using the same ad blockers in Chrome the pages load just fine.

That said, the only clear resolution seems to be not to use Firefox on YouTube and other video sites, but especially YouTube. It is simply doesn’t want to load pages on this site for any real amount of time. Or—quit using the browser altogether and switch to Chrome. Which I am sure is exactly what Google would like.

That said, if Mozilla can ever fix this bug—drop me a note. As I said, although it was already being quirky, it became completely dysfunctional after a recent update to the browser this month, specifically the one, though I'm not blaming this particular action, that changed the download manager. Until them… I will be moving my business over to Chrome.

Thank you for the years and good night.

more options

Hello,

I understand your concern. Because we can not recreate this issue, there is very low likelihood of it magically being "fixed." If you are annoyed with chrome and want an old version of firefox, use ESR; you can find more info at Switch to Firefox Extended Support Release (ESR) for personal use

more options

How do I turn off hardware acceleration?

more options

@Amelia I cannot think of a better way to frame the problem.

more options

You may be correct that it is hardware acceleration.

The default response for disabling hardware acceleration follows:

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

  1. Click the menu button Fx57Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

Thank you. I don't have "Options" in that menu anymore, it's Settings. But found it in Settings using the search feature. I only knew about this because I had a text reader that required me to turn the feature off so that the text reader would work properly.

I will keep this setting today and see how it goes and will let you know.

Thank you.

more options

I can't say that disabling hardware acceleration helped. YouTube pages still load hard, though it's a little random, but you just know when it's going to happen because everything just lags and suddenly, according to YouTube I am "offline." That said, there are still similar issues on other sites as well as my own blogs on Wordpress. What else am I missing? Who knows. But Firefox is no longer functional for me and I'm still saying that it only started occurring after a recent update.

I'm done. Perhaps another update will have some type of bug fix, but intil then--I'm scrapping the browser.

Screw it.

more options

I am sorry to hear that you feel this way.

If I may give you a last suggestion, use a privacy-respecting chromium variant like brave or ungoogled chromium. Don't sacrifice your privacy for this.

  1. 1
  2. 2