Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Squareup login fields not appearing in Firefox

  • 9 bhfreagra
  • 1 leis an bhfadhb seo
  • 30 views
  • Freagra is déanaí ó HLBirdsong

more options

When I go to https://squareup.com/login the entry fields do not appear in Firefox. It's impossible for me to access my Square account through Firefox currently, which I use for client invoicing. I have no trouble logging in through Chrome. Screenshot attached.

I have Privacy Badger and AdBlock installed for both browsers. I tried disabling them for Firefox just to see if that was the issue, but it made no difference. I am using an iMac running macOS Catalina version 10.15.7. My Firefox Browser is version 97.0.1, and currently shows that it's up to date. My Chrome browser is version 98.0.4758.109, also up to date.

When I go to https://squareup.com/login the entry fields do not appear in Firefox. It's impossible for me to access my Square account through Firefox currently, which I use for client invoicing. I have no trouble logging in through Chrome. Screenshot attached. I have Privacy Badger and AdBlock installed for both browsers. I tried disabling them for Firefox just to see if that was the issue, but it made no difference. I am using an iMac running macOS Catalina version 10.15.7. My Firefox Browser is version 97.0.1, and currently shows that it's up to date. My Chrome browser is version 98.0.4758.109, also up to date.
Attached screenshots

Réiteach roghnaithe

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

HLBirdsong, I'm on macOS, so I'm able to test it. When I do, the login screen looks fine. Do you have any other add-ons installed? If you start Firefox in Troubleshoot Mode, does the problem still occur? To start in Troubleshoot Mode, go to Help > Troubleshoot Mode.

If the problem does not occur in Troubleshoot Mode, then you can disable your extensions one-by-one until you find out which one is causing the problem. For more info, visit Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

Read this answer in context 👍 1

All Replies (9)

more options

I'm not able to replicate the near black-on-black look. Does your Firefox normally enforce a dark color scheme on sites?

Helpful?

more options

No, not at all – I'm not sure why the screenshot loaded that way. I'm having trouble uploading images — just keep getting the spinning wheel of death. But I'll try again.

Helpful?

more options

Previously added image shows the Firefox browser on the Squareup login screen. This is what it looks like in Chrome. I tried to add it to the previous reply, but it's only letting me add one at a time.

Helpful?

more options

Hmm, hard to explain why those other elements of the page do not load. Maybe you already tried this, but just in case:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just the Cached Web Content)

If you have a large hard drive, this might take a few minutes.

Any luck if your reload the page (Command+R) after that?

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Helpful?

more options

I cleared Cached Web Content and Cookies and Site Data for Squareup. I tried refreshing just that website, and then I tried quitting Firefox completely and re-opening. Alas, no change; I'm still not able to see the login fields. Thank you for the suggestions though, I appreciate the help.

Helpful?

more options

Make sure you haven't enabled High Contrast Mode in the OS settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with your selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

You can try to change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

Thanks cor-el for all of that; I appreciate you taking the time to help me troubleshoot. Unfortunately, none of it worked. I did not have High Contrast Mode on; override was always set to "Never"; changing the about:config settings had no effect; after making the about:config changes, I cleared cache and cookies, just in case.

I'm still not seeing the log in fields, and have to keep using other browsers for all of my business activities with Square. I think I just can't rely on Firefox to be my primary browser, unfortunately.

Helpful?

more options

Réiteach Roghnaithe

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

HLBirdsong, I'm on macOS, so I'm able to test it. When I do, the login screen looks fine. Do you have any other add-ons installed? If you start Firefox in Troubleshoot Mode, does the problem still occur? To start in Troubleshoot Mode, go to Help > Troubleshoot Mode.

If the problem does not occur in Troubleshoot Mode, then you can disable your extensions one-by-one until you find out which one is causing the problem. For more info, visit Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

Helpful?

more options

Wow, such a simple thing! It was an Audio Equalizer plug-in I use to reduce bass on streaming music and video (bass triggers migraines for me, so it's a life-saver). I never imagined. Whew! Thanks for the suggestion.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.