Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox scrolls up to the top of page when I click on any video link on Tiktok site.

  • 7 bhfreagra
  • 3 leis an bhfadhb seo
  • 155 views
  • Freagra is déanaí ó taseron

more options

Problem: Firefox scrolls up to the top of page when I click on any video link on Tiktok site.

Details:

  • Problem also exists in Private Window.
  • I tried disabling all Extensions and it didn't help.
  • Works normal only in Safe Mode.
  • Tiktok works fine with other browsers.
  • Page works normal 1 time after initial loading. I click on any video and it opens. When I exit video page and land back on video index, problem starts. Any mouse click (right,left and middle) makes FF jump to top of the page (even without scrolling. It's supposed to scroll just like when you press HOME on keyb.).
  • 2 different behaviors on Tiktok Main Feed vs Tiktok User's Feed. On the Main Feed, when I click on a video, I see the page jumps to top but it opens the video link after a 1/2 sec delay. On the User's Feed, video link doesn't open. It just jumps to the top and does nothing.

Version: FF 96.0.3 (64-bit) for Desktop PC OS: Win 7 SP2

Any suggestions to pin and fix this?

'''Problem''': Firefox scrolls up to the top of page when I click on any video link on Tiktok site. '''Details''': * Problem also exists in Private Window. * I tried disabling all Extensions and it didn't help. * Works normal only in Safe Mode. * Tiktok works fine with other browsers. * Page works normal 1 time after initial loading. I click on any video and it opens. When I exit video page and land back on video index, problem starts. Any mouse click (right,left and middle) makes FF jump to top of the page (even without scrolling. It's supposed to scroll just like when you press HOME on keyb.). * 2 different behaviors on Tiktok Main Feed vs Tiktok User's Feed. On the Main Feed, when I click on a video, I see the page jumps to top but it opens the video link after a 1/2 sec delay. On the User's Feed, video link doesn't open. It just jumps to the top and does nothing. '''Version:''' FF 96.0.3 (64-bit) for Desktop PC '''OS:''' Win 7 SP2 Any suggestions to pin and fix this?

Athraithe ag taseron ar

Réiteach roghnaithe

Issue is solved with Firefox 97.0.1 version update.

Read this answer in context 👍 0

All Replies (7)

more options

If the problem does NOT occur in safe mode, there can be reasons other than an add-on. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Helpful?

more options

I followed the guide you posted; "Diagnosing problems in Troubleshoot Mode" >>> "The problem does not happen in Troubleshoot Mode" ,

and I tested the following:

- Disabling hardware acceleration - Disabling all extensions - Switching back to Default Theme


Unfortunately it did not fix the problem. I also tried disabling Kaspersky Internet Security and removed the plugin that injects code into HTML but it did not fix the issue. (I even tried switching the mouses with another PC thinking it might be a mechanical issue.)

This issue is weird! I see 2 people marked `I also have this` on this post. I wonder what their hardware and software specs are.

Athraithe ag taseron ar

Helpful?

more options

I have a similar problem. While surfing, if I find something I want to check out, I open a new tab/window. When I am done, I close it and am returned to where I was. But for a while now, sometimes when I return, the page has moved to the top.

Helpful?

more options

FredMcD said

I have a similar problem. While surfing, if I find something I want to check out, I open a new tab/window. When I am done, I close it and am returned to where I was. But for a while now, sometimes when I return, the page has moved to the top.

Thanks for your feedback. Do you have this only on Tiktok or other sites too?

And what is the version of FF and OS platform?

Helpful?

more options

It does not happen all the time. I did not track what sites this happens on.

Helpful?

more options

I have this issue as well. I'm running Firefox 97.0 on Windows 10 21H2.

EDIT: I rolled back to 96.0.3 and the problem is resolved for me, at least for now. To do this, I had to: 1) Download the old version 2) Go to the profile folder and delete compatibility.ini (to get rid of the obnoxious downgrade prevention) 3) Install the old version 4) Upon running it, IMMEDIATELY go to settings and disable auto update. It seems these new versions re-enable that upon install, which is also extremely obnoxious. 5) Delete the cookies for Tiktok. The existing ones caused an error when loading TikTok

Once I did all this, TikTok works as expected. That said, it seems every new version creates some new problem, or just makes the UI worse. Combined with the annoying downgrade protection and them now auto-enabling updates upon upgrading/downgrading, I may be about done with Firefox. Sadly, it's the only real option for a non-chromium based browser out there, so I want to support it. But, with the direction it's going, I'm not sure how much longer I can.

Athraithe ag beefjerky1 ar

Helpful?

more options

Réiteach Roghnaithe

Issue is solved with Firefox 97.0.1 version update.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.