Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Google won't stay signed in

  • 4 fhreagra
  • 2 leis an bhfadhb seo
  • 1828 views
  • Freagra is déanaí ó Joseph

more options

I recently changed Firefox settings to delete cookies for everything when I close it except the sites I use frequently. This has worked great for everything except for Google sites which sign me out every time I close the browser.

I assume there are some supporting sites for signing in to Google that need to be in the exception list, but I don't know what they might be. I'm also using Mozilla's new Multi-account Container extension in case that matters.

Thanks for taking the time to read this.

I recently changed Firefox settings to delete cookies for everything when I close it except the sites I use frequently. This has worked great for everything except for Google sites which sign me out every time I close the browser. I assume there are some supporting sites for signing in to Google that need to be in the exception list, but I don't know what they might be. I'm also using Mozilla's new Multi-account Container extension in case that matters. Thanks for taking the time to read this.
Attached screenshots

Réiteach roghnaithe

Probably you have an exception for the secure address

https://google.com

as well. If not, definitely add one.

You also can open the Storage Inspector (Shift+F9) while on a Google page to see what other domains are used for cookies there.

If you are putting Google in a container, you might need to put multiple Google domains in the same container.

Read this answer in context 👍 1

All Replies (4)

more options

Hi Joseph, what exceptions did you add for Google? If you haven't already, try the "base" domain google.com without any additional subdomains to the left of that.

more options

Thanks for getting back to me, J. I tried like you said (Screenshot 1), but no luck there. When I open a Google page I get what you see in Screenshot 2.

The strange thing is that if I click sign in, it logs in immidiatly with no need for the password or 2FA. However, in Screenshot 3 you can see a message I'm getting on the Google homepage every time I sign in. This message re-appears even if I do the security check.

It's as if only some of the cookies for login are being retained while the rest are being deleted.

more options

Réiteach Roghnaithe

Probably you have an exception for the secure address

https://google.com

as well. If not, definitely add one.

You also can open the Storage Inspector (Shift+F9) while on a Google page to see what other domains are used for cookies there.

If you are putting Google in a container, you might need to put multiple Google domains in the same container.

more options

That did the trick. I had to add ogs.google.com to the exception list for all the needed cookies to be saved. Adding that also fixed other Google sites.

Thanks for all your help.