Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The background colour for some parts of the webpages has changed making it hard to read.

  • 25 freagra
  • 2 leis an bhfadhb seo
  • 38 views
  • Freagra is déanaí ó Cyclone Boom

more options

I know and admit I stuffed up.

One day a long time ago I was prompted for my master password.

When I clicked in that area/field a requester popped up asking me to pick a colour. Confused I picked one - and a bad one I now see.

So now when certain parts of a web page are opened the background colour is this horrible colour and I can't really read what is there.

I don't understand what I did or HOW I did it.

This is a cropped example of the bad contrast I am seeing.

file:///home/me/Pictures/Screenshot%20from%202022-01-22%2010-09-48.png

As I said, I admit I stuffed up. But this seems to all have happened since that one time with the main password requester.

I know and admit I stuffed up. One day a long time ago I was prompted for my master password. When I clicked in that area/field a requester popped up asking me to pick a colour. Confused I picked one - and a bad one I now see. So now when certain parts of a web page are opened the background colour is this horrible colour and I can't really read what is there. I don't understand what I did or HOW I did it. This is a cropped example of the bad contrast I am seeing. file:///home/me/Pictures/Screenshot%20from%202022-01-22%2010-09-48.png As I said, I admit I stuffed up. But this seems to all have happened since that one time with the main password requester.

All Replies (20)

more options

Hi, Firefox 96 behaves differently than Firefox 95. When the text color on your toolbar theme is light/white, that triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. Firefox also signals sites that you have a dark theme preference.

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs. That doesn't need to be blinding, it can have a pastel color.

If you go to the Add-ons page, Themes panel, there are many choices. The key is the text color.

Use themes to change the look of Firefox

If you want something more creative, there are examples of these that trigger Light mode:

Helpful?

more options

Thanks, I think. (Nothing against you.) I am really having bad days)

This is what the theme screen says.

file:///home/me/Pictures/Screenshot%20from%202022-01-22%2011-07-57.png

So as far as I know things should be ok.

I changed to the light theme as you said (Oh my eyes!)

This is what I get.

file:///home/me/Pictures/Screenshot%20from%202022-01-22%2011-10-18.png

(I'm going to have to go back to the dark theme. My eyes hurt)

Helpful?

more options

I think you need to attach the images using the Browse button below the box where you type. They don't seem to be attaching using the method in your last reply.

Helpful?

more options

teeny_weeny said

This is what the theme screen says. file:///home/me/Pictures/Screenshot%20from%202022-01-22%2011-07-57.png This is what I get. file:///home/me/Pictures/Screenshot%20from%202022-01-22%2011-10-18.png

One cannot host images on your own private desktop or laptop computer. You need to host the image at say a image host (there are a number of free ones) or attach the image to your reply.

Look at bottom of the reply box where it says Add images (optional): [Browse...] button.

Helpful?

more options

Is it only one web page or are all web pages affected?

Helpful?

more options

Sorry... So many forums so many different ways...

Ok, selecting the bright theme, I get this

Gee, opening the `attach picture` and picking it makes a snail look fast. All that is happening is a spinning wind mill.

And it is still spinning a few minutes later.

Stuck on what to do now.

Helpful?

more options

Ok, to the other questions:

It is many web pages.

Originally it was the text box area where I enter my main password for saved log ins.

Now it is other pages on other sites....... Though "site" is a bit hard to pin down with the "master password" requester.

So I would say many.

Again: Tried to "add image" (browse) and after selecting a picture all I see is a spinning wind mill.

Helpful?

more options

For me, if an image doesn't attach within 10 seconds, I copy the text of my unsubmitted reply then reload the page. The image always attaches quickly after a reload. I don't know why it sometimes stalls.

Helpful?

more options

Ok, going off reservation:

https://anonfiles.com/H8Q7J0C7x5/Screenshot_from_2022-01-22_11-07-57_png

https://anonfiles.com/FeQ8JcCaxf/Screenshot_from_2022-01-22_11-10-18_png

https://anonfiles.com/JbQeJdC7xe/Screenshot_from_2022-01-22_11-48-03_png

Dark theme - as I have it.

Light theme - as suggested.

Examples of where it is being messed up.

No change to that part of the screen.

Look right hand side of screen on the last two for the problematic area.

Athraithe ag teeny_weeny ar

Helpful?

more options

(This is frustrating.)

Ok, I edited my post and it is awaiting approval before it is visible.

So as to not keep you hanging on.

(Going off reservation for pictures)

This is my background as is. https://anonfiles.com/H8Q7J0C7x5/Screenshot_from_2022-01-22_11-07-57_png

I changed it to light theme. https://anonfiles.com/FeQ8JcCaxf/Screenshot_from_2022-01-22_11-10-18_png

Look at the right part of the screen towards the bottom. (Sorry I should have pointed to it before uploading)

Sill not readable.

And this is what I see status quo https://anonfiles.com/JbQeJdC7xe/Screenshot_from_2022-01-22_11-48-03_png

So, I am either missing something or...... really messed something up.

Helpful?

more options

For the website, once it has detected a dark mode preference, in order to switch it after you change your theme, you might need to:

  • Check whether the site has a menu setting for color scheme
  • If it's automatic, reload the page
  • If reloading doesn't help, delete the site's cookies

You also can set Firefox to tell sites you have a light mode preference. Currently, it's through the back door:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change. However, websites might need a kick in the seat of the pants as mentioned previously.

Helpful?

more options

Ok, thanks.

Just as an "acid test" I could open the page in a "private browsing" and should see things happen to establish if what I did works or not?

(It makes no change.)

The layout.css.prefers-color-scheme.content-override was `3 and tried `0` and `1`. No change.

But am I right with the private browsing being a good starting pint?

Helpful?

more options

This is the original screen that started this whole fiasco.

The red arrow points to the colour that somehow got changed.

I got this screen, was clicking on the "use saved logins" - or something - and a colour requester popped up. Since then it hasn't and that colour was the one I picked, not knowing the knock on affect.

Thoughts?

Helpful?

more options

teeny_weeny said

Just as an "acid test" I could open the page in a "private browsing" and should see things happen to establish if what I did works or not? (It makes no change.)

Private browsing bypasses cached pages and cookies from the site so you should see it in its "first time visitor" form.

teeny_weeny said

This is the original screen that started this whole fiasco. The red arrow points to the colour that somehow got changed.

The problem is the yellow-ish color in the login form fields?

Firefox does apply a color filter to fields that it auto-filled. Usually it's a bright yellow when the field is white, but maybe the color you see is a blend of yellow and whatever color is normally there?

What is the color if you delete the values from the fields?

I got this screen, was clicking on the "use saved logins" - or something - and a colour requester popped up. Since then it hasn't and that colour was the one I picked, not knowing the knock on affect.

Did the popup look like the Colorways overlay (see attached screenshot)?

That's the only one I think Firefox would show and that would change your theme, but you could change it to a different theme.

Helpful?

more options

> The problem is the yellow-ish color in the login form fields?

Yes.

> What is the color if you delete the values from the fields?

You have lost me there. I don't know how to do that.

> Did the popup look like the Colorways overlay (see attached screenshot)?

No. From memory it was a checker board style.

Helpful?

more options

Firefox changes the background of a form when this form is auto-filled like in a login form with username and password to make you aware that the credentials are filled as a security measure.

  • about:config => ui.-moz-autofill-background = rgba(255, 249, 145, .5)

Helpful?

more options

I went to that config setting and looked.

I am seeing the same values as what you posted.

Helpful?

more options

teeny_weeny said

> The problem is the yellow-ish color in the login form fields? Yes. > What is the color if you delete the values from the fields? You have lost me there. I don't know how to do that.

I meant just clicking in the form fields and deleting the auto-filled text.

Helpful?

more options

Well that did something.

But it hasn't fixed ALL the occurrences.

(Weirdly)

See pictures.

Helpful?

more options

I could recognize when autofill was marked, but I don't know what that web app normally looks like, so I can't tell what is wrong in those screenshots compared with other browsers.

Helpful?

  1. 1
  2. 2
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.