Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox saving to /run/user/1000/docs

  • 13 freagra
  • 2 leis an bhfadhb seo
  • 674 views
  • Freagra is déanaí ó jonzn4SUSE

more options

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

Réiteach roghnaithe

Delete places.squite. You just proved it's a SNAP issue and not Mozilla. Reporting the issue to Ubuntu team would also help others with the same issue.

Read this answer in context 👍 0

All Replies (13)

more options

The same thing happens to me on Windows 10. All files save to the temp folder. I have found a bit of a workaround though. If you are okay with having to choose your file location every time you download a file. There is a setting in the Files and Applications under the subsection Downloads section called "Always ask where you save files". It will always pull up the file explorer when you want to download something, but I find it as a good workaround. Mozilla will hopefully fix it in a update coming soon. Let me know if you have any questions! NuggFrog

more options

Thanks for your reply NuggForg, but changing the setting makes no difference. Upon choosing Save Image it still defaults to the /run/user/1000/doc directory and regardless of where I choose saves a duplicate there. Weirdly, the other thing I've noticed is that each time I start Firefox it is now creating a directory in my downloads folder called firefox.tmp which has initially a temp folder containing a sub-directory called mesa_shader_cache, and after a bit of use one called dnd_file. Finally, there doesn't appear to be a .mozilla folder in the Home directory as I believe there used to be. Maybe there is an installation fault not creating that dump folder that's causing temp files to be randomly stored through the system. Sadly I don't know how to highlight the issue with Mozilla other than posting here.

more options

Go to your profile directory. see screenshots Look for the file places.sqlite. Move it to trash, this should reset your download location. Close the browser and reopening it should show that you download location is back to "Downloads".

Athraithe ag jonzn4SUSE ar

more options

I also recommend having more than just your distro version of Firefox. Download another copy of Firefox and run it from the folder to tests this and future issues.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

NuggFrog said

The same thing happens to me on Windows 10. All files save to the temp folder. I have found a bit of a workaround though. If you are okay with having to choose your file location every time you download a file. There is a setting in the Files and Applications under the subsection Downloads section called "Always ask where you save files". It will always pull up the file explorer when you want to download something, but I find it as a good workaround. Mozilla will hopefully fix it in a update coming soon. Let me know if you have any questions! NuggFrog

You can try the same steps.

more options

Thanks Jon, I did a system wide search for places.sqlite and the only place it found the two files you show in your screenshot were in the downloaded snap, i.e. home/snap/firefox/common/.mozilla/firefox/9vis8bof.default. I did delete that places.sqlite and restarted but it made no difference to the download location and the system just recreated the file in that snap directory.

more options

Oh Snap...  ;-/ Right, after deleting the file the browser does recreate the file. Did you download a copy of Firefox to see if you have the same issue?

Athraithe ag jonzn4SUSE ar

more options

To be honest Jon I went to the link you posted which download a tar.bz2 folder. I googled how to install from a tar.bz2 and the first link was to ubuntu forums where the answer was "you should at all costs avoid installing duplicate programs from tar files as they could potentially bork your system". So, you'll appreciate I'm a little wary of doing that as I lost most of a morning's work yesterday after Firefox broke after the Ubuntu upgrade. So, in the short term I'd rather put up with the minor inconvenience of duplicated downloads than risk another major system failure.

more options

You are not installing anything. You just downloading, unzipping, and then running the app. I have several version of Firefox all running from my Downloads folder. see screenshot

Here are the cmds... bunzip2 firefox-97.0b3.tar.bz2 then tar -xf firefox-97.0b3.tar then go into the Firefox folder and find the file in the screenshot to run.

Athraithe ag jonzn4SUSE ar

more options

Also, I'm here to help and it wouldn't be helpful if I did something to cause you a problem... I wouldn't tell you do something I haven't already done myself. You learn when you do new things... so lets go Paul!  ;-))

Athraithe ag jonzn4SUSE ar

more options

Thanks Jon, not suggesting you were trying to mess things up, just didn't want to change things in the middle of work. Anyway, the one I downloaded was firefox-96.0 and running that it did work fine - downloads to the right place, no odd folder created in the downloads folder, etc. So it sounds like there's a problem with the snap file in the main ubuntu software program. So I'll try to remove the snap one and use the new one as the default. Thanks for your help, I'm not sure if that means this thread is solved or whether I should try to report it to the programmers.

more options

Is it places.squite, places.squite-shm, or places.squite-wal that i need to delete?

more options

Réiteach Roghnaithe

Delete places.squite. You just proved it's a SNAP issue and not Mozilla. Reporting the issue to Ubuntu team would also help others with the same issue.