Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some extensions not working after update to 96.0 on Linux

  • 2 fhreagra
  • 1 leis an bhfadhb seo
  • 34 views
  • Freagra is déanaí ó jonzn4SUSE

more options

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning.

uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js

2) Toolbar icon does not show blocked items count (probably due to above)

3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content.

4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes.

5) After removing and re-installing the add-on, its button does not appear on the toolbar.

6) After creating a blank profile and installing the add-on, all the above still happens.

7) After downgrading to firefox-bin-95.0.1, all the above still happens.

Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works.

2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though.

Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup.

2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning. uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js 2) Toolbar icon does not show blocked items count (probably due to above) 3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content. 4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes. 5) After removing and re-installing the add-on, its button does not appear on the toolbar. 6) After creating a blank profile and installing the add-on, all the above still happens. 7) After downgrading to firefox-bin-95.0.1, all the above still happens. Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works. 2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though. Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup. 2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

Réiteach roghnaithe

I found that all these symptoms are cured by running firefox with the following environment variable set:

MOZ_DISABLE_CONTENT_SANDBOX=1

Details about the issue at these links (am still reading through them):

https://forums.gentoo.org/viewtopic-t-1141441.html https://bugs.gentoo.org/803950

Read this answer in context 👍 0

All Replies (2)

more options

Réiteach Roghnaithe

I found that all these symptoms are cured by running firefox with the following environment variable set:

MOZ_DISABLE_CONTENT_SANDBOX=1

Details about the issue at these links (am still reading through them):

https://forums.gentoo.org/viewtopic-t-1141441.html https://bugs.gentoo.org/803950

Helpful?

more options

Try downloading another copy of Firefox and run it from the folder. Sign into your Firefox account (make sure you have sync set so that you ad-ons come over)and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Athraithe ag jonzn4SUSE ar

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.