Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens with blanks screen will not load tabs, options, about:config won't work.

  • 12 freagra
  • 1 leis an bhfadhb seo
  • 33 views
  • Freagra is déanaí ó FredMcD

more options

This is going to be long sorry. A lot has transpired

My son was using 78.15esr. I upgraded it to 91.3esr. After the upgrade the browser worked; tabs loaded, surfing was fine, could go into settings and about:config was fine.

He went to watch something on Netflix. Netflix complained his browser was not supported and he needed to upgrade to the latest version - which at the time was 91.3esr.

In frustration he installed Chrome. When he tried to run it he was told software restrictions were in place. I had not set any restrictions, and I checked secpol.msc and there were definitely no path rules defined. If restrictions can be set in group policy I had not set them because I am unaware of them.

So he installed Microsoft Edge, which installed VC runtime for 2013 and 2015-2019 for both x64 and x86.

At that point Firefox no longer loads tabs at all. About:<anything> doesn't work. Settings doesn't work. You can't go to safe mode (more on that later), and when closing the browser two processes remain taking about 60 seconds to end.

I did have the group policy templates for Firefox installed. When I upgraded to FF 91 I installed the latest templates.

A couple of times when I started FF it complained about vcruntime140 was missing. But just running FF again worked without doing anything else.

So I reverted to 78.15; I uninstalled v91.3esr. I deleted his profiles.ini and profiles folder and then copied them back from a back up. I removed any registry settings, and copied back the v78 ADML files. I then installed v78.15esr with internet disconnected. Did not run FF after install. Went into group policy editor and turned off telemetry and auto updates then re-enabled internet

Run FF and same issue. tabs not loading. Pages not loading. I can click on a menu and I can type into navbar and search bar but there is no response. I checked internet was working.

I deleted the %LOCALAPPDATA% cache folders. I flushed the DNS cache. None of this worked.

So I uninstalled FF again, deleted the profile folders and ini. Disconnected from Internet. Deleted any registry settings, and removed the group policy templates. Then installed 78.15 from scratch and let it create a new profile.

Same darn problem. It seems to me that installing chrome and/or edge has done something nasty, but I have no idea what. I say that because before he did that he could surf the web, but Netflix just said his browser ver was outdated.

I tried contacting netflix on chat but they were worse than useless.

So I uninstalled again and removed everything. Connected the internet and installed FF again and let it update automatically. Same problem.

I've left him with edge but I need to fix FF.

I even uninstalled the VCLibs, Chrome and Edge. These did not fix the problem.

I tried safe mode but when firefox restarts there are two processes that take 60+ seconds to end so FF sits there saying "restarting...". When those processes finally end Firefox does not restart.

Checked for viruses; nothing found. Rebooted PC several times.

So at this point in time; FF will run but will not load the 3 tabs; Facebook, Netflix and youtube. They stay blank. Settings is not accessable, nor is addon's or logins and passwords. Typing anything on the search bar does nothing Typing anything in the address bar does noting Trying about:config or about:profile or any other about's does nothing. When closing FF two processes take 60+ seconds to end.

If I go back to him and tell him I need to reinstall Windows he will go absolutely nuts.

What also worries me is that Netflix said that the most recent esr browser version was not supported and that he should update to a later version.

And what is even more troubling is I updated his girlfriends PC at the same time and hers works perfectly. This scares the hell out of me because I then expect responses like "Your sons problem is not a firefox problem".

Réiteach roghnaithe

I called for more help.

Read this answer in context 👍 0

All Replies (12)

more options

citizen1138x said

. . . . So he installed Microsoft Edge, which installed VC runtime for 2013 and 2015-2019 for both x64 and x86.

We have seen many issues with the problem turning out to be with;


You can check for issues caused by a corrupted or incomplete Visual C++ installation that is missing runtime components (Redistributable Packages) required by Firefox, especially VCRUNTIME140_1.dll.

Install both 32-bit and 64-bit "Visual Studio 2015, 2017 and 2019" downloads, (x86: vc_redist.x86.exe and x64: vc_redist.x64.exe) from https://support.microsoft.com/help/2977003/the-latest-supported-visual-c-downloads

You may not need the latter (32-bit version) if you use 64-bit Firefox. You may have to reboot the computer. ++++++++++++++++++++++++++++++++++++++++++++++ In another thread, a user reported that a recent update of Malwarebytes Anti-Exploit (version 415) may be causing symptoms similar to the VC Runtime problem. If you have MBAE, it should have a setting to exempt Firefox. You could test whether that makes any difference.

Helpful?

more options

Thanks for your reply.

Before I go uninstalling/installing anything else;

When the PC was installed all VC runtimes are installed from a single AIO installer created by aboddi1406 from MyDigitalLife from his github page; https://github.com/abbodi1406/vcredist/releases (v50.5). This installs all VC runtimes x86 and x64 from 2005 to 2019.

Since the PC's apps and setting are updated via an automation script and programs are installed silently where possible, it was just easier to install all the VC's at once, which is done at the start of the script, so dependencies for any programs were then catered for.

Question: I'm guessing the versions of the libs used by various programs are registered within the OS. Would uninstalling all VCs and then reinstalling from the v50.5 installer be likely to cause other problems?

It seems to me uninstalling then reinstalling should fix things as long as I use the same installer so the lib versions are identical to what were installed originally?

What are your thoughts?

Athraithe ag citizen1138x ar

Helpful?

more options

That is above me and I called for more help.

Helpful?

more options

Just to reinforce the earlier point, if Firefox is operable from the address bar down, the most common reason is a missing VCRUNTIME140_1.DLL file. I don't know why you get the message intermittently, but either way, to rule out that issue, you can (re)run Microsoft's latest installer for the VC Runtime files:

(A) Open https://docs.microsoft.com/en-US/cpp/windows/latest-supported-vc-redist?view=msvc-160#visual-studio-2015-2017-2019-and-2022

(B) In the "Visual Studio 2015, 2017, 2019, and 2022" section of the article, download the installer for your system:

  • 64-bit Windows: the "X64" download
  • 32-bit Windows: the "X86" download

(C) Run that installer and restart Windows.

Any improvement?

Helpful?

more options

Réiteach Roghnaithe

I called for more help.

Helpful?

more options

Um, Firefox is not operable at all. I can open it and that's all.

No tabs load and no content is displayed.

The only thing that does work is I can right click to show context menu, but none of the option on it work, and I can click the hamburger menu but none of the options on it work.

I shall re-install all the VC again after taking an image of the PC and let you know how it goes.

My son is unavailable today so I can't visit his PC. Probably tomorrow.

Helpful?

more options

Ok I managed to get access to the PC.

Installed the VC Runtimes and restored 78.15 from backup then upgraded to 91.4.1esr

Browser now working fine. However, Netflix and Disneyplus both say the browser is out of date and to upgrade to the latest.

So checked other PC. Same FF ver. Same VC runtime vers same WIndows, same patch level. All works perfectly.

Getting Netflix error FF7701-1003... The solution to which is to update to the latest browser. Cleared cache, rebooted, no fix.

reverted to FF78.15esr and everything works.

Helpful?

more options

citizen1138x said

. . . However, Netflix and Disneyplus both say the browser is out of date . . .

There is software that changes the browser's User Agent.


https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/


Do you have enabled "Resist Fingerprinting" if you check ‘’’Resist Fingerprinting’’’ on the ‘’’about:config’’’ page as this affects the user agent?


’’’Avast AntiTrack’’’ is also known to cause this issue.

Helpful?

more options

I don't mess with stuff like that. I wasn't even aware that setting existed. Just checked my PC - it's off. If false is the default it will be off for all PCs.

I've turned on stylesheets, turned off autoupdate and telemetry and enabled legacy profiles. That is all.

There are no A/V programs interfering with his system.

I checked the group policy and registry for both PCs. They are identical.

Both are using standard tracking protection. Both are running uBlock Origin, but I tried it with it on and off on both PCs.

Both run discord, runescape, steam, overwolf, epic games. But tried with all of that stuff disabled. And they've been running some of that stuff for over a decade.

My user agent is Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0, so expect the sons' girlfriends PC will be the same as she is on 91.4.1 with Netflix working

I personally hate netflix - because of issues like this, terrible support, and in Australia we get about 10% of the total library for double the US price and often have to wait a year for some series to be available. No thanks. So I can't test it on my PC.

I'm out of ideas. I'm going back tomorrow. One suggestion I saw somewhere was the do the update multiple times, claiming sometimes the first one doesn't "take". Sounds bizarre, but what have I got to lose.

Helpful?

more options

citizen1138x said

One suggestion I saw somewhere was the do the update multiple times, claiming sometimes the first one doesn't "take". Sounds bizarre, but what have I got to lose.

The update for Widevine, the plugin used on sites like Netflix that apply Digital Rights Management to their video? You can try disabling DRM, waiting a minute for Firefox to unload the old plugin, then re-enabling DRM and see whether that helps on the next visit to Netflix.

Watch DRM content on Firefox

Helpful?

more options

Ok, got it. It doesn't appear to have been widevine as widevine was not showing, despite the fact that DRM was ticked.

So I disabled DRM. enabled DRM, widevine Shows up. Netflix still issued the same error. So I went back to scratch. Installed 78.15 et al. Upgraded to 91.3 et al. Upgraded to 91.4.1 It now works.

To summarize; The problem with FF "crashing" was the VC runtimes that the Edge install seems to have corrupted. The Netflix problem seems to be what I saw on another post here... to do multiple updates.

Thank you for your help.

Athraithe ag citizen1138x ar

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.