Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Web Browser Configuration for local Preview

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 15 views
  • Freagra is déanaí ó cor-el

more options

Hello,

With the previous version of Mozilla Firefox, I was able to preview my work by passing privacy.file_unique_origin to false.

Now with the new update (95.0), it doesn't work anymore.

Can you please provide a solution to this issue?

Thanks in advance

Hello, With the previous version of Mozilla Firefox, I was able to preview my work by passing privacy.file_unique_origin to false. Now with the new update (95.0), it doesn't work anymore. Can you please provide a solution to this issue? Thanks in advance

All Replies (3)

more options

Same for me here since FF 95.0. I have a long-running test application that at intervals chunks out a test-result that needs to be appended to the overall report. Instead of re-saving the entire report over and over again, I safe the newest test-result separately, and then recreate the 'index' report. The 'index' report is supposed to load all partial results, whereby the partial results get loaded by a little java-script. The javascript fetch command as shown below always worked for me, but not anymore.

PS: Just as the user above I double checked that privacy.file_unique_origin is still false (not the Firefox default)

< !DOCTYPE html> < html>

 < head>
   < meta charset='UTF-8'>
   < link rel='stylesheet' href='lt.css'>
   < script type='text/javascript' src='lt.js'></script>
 < /head>
 < body>
   < div class='js-include' data-name='test4.16.html'></div>
< div class='js-include' data-name='test4.17.html'></div>
<script> const components = document.querySelectorAll('.js-include') const loadComponent = async c => { const { name } = c.dataset const response = await fetch(`${name}`) const html = await response.text() c.innerHTML = html const tabs = c.getElementsByClassName('defaultOpen'); for(const i of tabs) i.click(); } [...components].forEach(loadComponent) < /script> < /body>

< /html>

more options

I saw in a post on Reddit (by a person familiar with the internals) that privacy.file_unique_origin was removed from the code in Firefox 95.

You might have a lingering custom preference, but the icon at the right end of the bar will have changed from a reset arrow to a trash can.

For previewing purposes, you could work around this by running a web server on your computer. I'm not sure about the index generation script; that might need to be done using some other tool. Or another browser if it is less restrictive than Firefox.

History note: This preference was introduced in Firefox 68 to address CVE-2019-11730 to resolve the issue that all local files in the same folder had "same-origin" privileges to one another's content and data.

more options

This pref got removed in Firefox 95.

  • 1732052 - Remove pref privacy.file_unique_origin
  • 1745987 - Browsing local files no more possible

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Athraithe ag cor-el ar