Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Background turned black after 95.0 update

  • 38 freagra
  • 15 leis an bhfadhb seo
  • 6447 views
  • Freagra is déanaí ó Paul

more options

I just updated to 95.0. I use default Firefox home page with the Search bar. The background turned to black with this update. The background has also turned to black for some of my bookmarks or sites I go to. Settings, Language and Appearance, Colors, Text is Black and Background is White. I have never changed that. How do I get the background back to White?

I just updated to 95.0. I use default Firefox home page with the Search bar. The background turned to black with this update. The background has also turned to black for some of my bookmarks or sites I go to. Settings, Language and Appearance, Colors, Text is Black and Background is White. I have never changed that. How do I get the background back to White?

Réiteach roghnaithe

You can change this pref on the about:config page from 3 to 2.

*layout.css.prefers-color-scheme.content-override
Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 3

All Replies (18)

more options

LucianDK said

First about:config in a blank page. Click away the warning and add browser.theme.toolbar-theme set it to 1 and voila, the bookmarks is now white with black text without needing to change the theme.

Please note that this is temporary because every time Firefox opens a new window, it recalculates the proper value of that preference based on your current theme. But if you are a single-window person, it might be a practical temporary workaround.

more options

jscher2000 said

LucianDK said

First about:config in a blank page. Click away the warning and add browser.theme.toolbar-theme set it to 1 and voila, the bookmarks is now white with black text without needing to change the theme.

Please note that this is temporary because every time Firefox opens a new window, it recalculates the proper value of that preference based on your current theme. But if you are a single-window person, it might be a practical temporary workaround.

I just discovered that. :( Any idea on how to make it permanent?

more options

This is ridiculous. Find the bug and fix it. My solution is to search out better browser options.

more options

gaylv said

This is ridiculous. Find the bug and fix it.

It's not a bug.

It is intentional that Firefox 96 harmonizes more parts of Firefox with your toolbar theme's color scheme.

It also is intentional that Firefox 95+ signals websites that you have a dark theme preference if the text color on your background tabs is light/white.

I understand that there is a disconnect here!

Fictitious conversation:

Mozilla to Users: "Since you prefer light colored text on your toolbar theme, you probably want the rest of the browser to also use a dark theme."

Many Users to Mozilla: "No, just because I hung a painting of Starry Night does NOT mean I want the walls painted to match."

Me to No one in Particular: "We need a simple setting for this so everyone can be happy. But I know the odds of getting that quickly are low as all UI decisions seem to take a long time.

more options

Didn't have this issue with 95 but got it with 96.

It's frankly a pain in the ass because I get headaches if I read light text on dark backgrounds for more than a few minutes.

I get that someone is trying to fix something that should have been there for a while but what you actually had was also very useful to some of us.

What would be great therefore is an option to be able to display browser content in colour schemes to follow the website or folllow the OS/browser scheme or to be able to override the site schemes with always light (as it was and my personal preference) or override with always dark schemes.

- If that's what all the options and config parameters are meant to achieve then they aren't working right here and I can't find a combination that does. Pretty much 40% of sites are now showing dark.


Why you want it to be controlled by the theme seems a little odd. I just choose my theme based on the graphic and actually haven't changed it for 4 years. Why would I want to use a theme to control whether or not I get a dark background from a website. The theme is (or at least I thought it was) all about controlling the look of the browser itself, not what it displays.

As for how it looks:

I have Windows set to light and associated image shows what I get in FF 96.

It's supposed to be showing text dark and background light from options or from system theme.

Athraithe ag fred.d1 ar

more options

Hi fred.d1, Firefox 96 amped up the approach of Firefox 95.

It certainly would be better if this were on the Settings page, but... did you already try the about:config change, which should help with the Settings page and websites?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

Note that doesn't change the theming for the sidebar, menus, or toolbar drop-down panels. Those are still tightly linked to your toolbar theme text color.

more options

jscher2000 - TBH I haven't used the about:config. I've worked around it by temporarily taking an old light theme as that doesn't seem to suffer with dark panes/menus and config pages.

I'm just being a grumpy old man because as it stands FF isn't doing what it says in the colour configuraiton settings.

Yes, I can set that config option and having read your last post I see it'll probably do almost what I asked for, probably will when it works correctly! It's just not in the settings page... Which given that this is something that will be affecting many, many people, it would seem to me to actually be a candidate for being out there in the open in the settings - even if that simply sets the config option.

So thanks for the response and I'll watch this space to see how it's eventually resolved.

To be fair I guess I should make the comment that if the theme is meant to control the look and feel of the browser then it's actually right if it controls the bookmarks/history panes and the settings pages as these are techniically part of the browser, not site or file content.

......

Unfortunately tho' every 3 or 4 releases I seem to end up adding more about:config changes to maintain the look and feel how I like/want/find FF to be most effective. It's always interface changes that hack me off the most. We all work differently but when something has been "that way" for a long time options to maintain it as it is ought to be offered - i.e. planned for, built in, TESTED and clearly explained.

Usually it's actually not the change itself that makes me unhappy as by and large options to work around are there. It's the fact that I waste 20 -30 minutes finding out what's going on, choosing the best way to solve it and then implement it. I love computers, I've been working in IT and entertaining myself with them for 40 years (ulp!) but that doesn't mean I want to spend time fixing things that maybe could, with some care, have been avoided in the first place.

For each 10000 users that's about 3 user man years of effort sorting things out and .7 of a year's worth of device and internet power in many locations. Don't know how much but it's certainly must help to warm the planet a little, which we could all do with avoiding.

...and yes I know that FF is provided to me for free and I am really grateful for all the effort devs and others put in to achieve that and I know that sometimes compromises have to be made and that I can't have everything that I want but...

did I mention that I'm old and grumpy :-)

more options

Out of interest, I've noticed also that since this update I'm seeing borders on some page items on some sites whereas before there were none. See attached image for startpage where it's most obvious. Not had this before and don't get it with Chrome or Edge. It's not intrusive like the dark theme but still distracting visually and I'd like to understand what's going on so that I can change it.

Tried searching but I haven't seen mention of this anywhere else or found anything that touches it in general "fix display issue" type posts.

Thanks.

more options

fred.d1 said

Out of interest, I've noticed also that since this update I'm seeing borders on some page items on some sites whereas before there were none. See attached image for startpage where it's most obvious.

I haven't seen that. I'm using the basic "Light" or "System" theme. Should I test a different one?

Also, can you confirm you do not use a "High Contrast" system theme? To rule that out, you can use the steps in the following article: Disable high contrast mode in Firefox.

more options

Hmmm, to answer your question I get that border effect with Light theme, or disabling all themes (not quite sure what that actually does). In fact tonight I noticed also that on the bbc.co.uk website football league tables, items that should be presented in highlighted boxes are actually being presented as normal text. - See images should be and shows as. Tried disabling high contrast using the method that you suggested and that gets rid of the box effect and the highlighting problem BUT it also means that a number of websites (not all) show dark backgrounds with light text. So in a sense it's progress but not where I want it to be. However I'm not quite sure why that of itself disables high contrast because the explanation in teh colours dialogue implies that if I set it to never it doesn't use Windows settings. if I go to my windows display settings I'm not using high contrast anyway.(see image ... contrast).

I guess I'll try using the about:config option tomorrow and see if that gets me closer but frankly I'm now only following this up to find out what is going on as I can just use another browser to give me what Firefox used to, at least display wise. If I can't find a fix soon it will be quicker for me personally to learn to configure Chrome on the PC to do the other things that I have set up Firefox to do over the last 10 years and learn the Chrome add-ons ecosystem.

Funnily enough this is similar to what happened last year with the Android version. The family found the interface was just too different and none of us liked it after one of the upgrades. In the end I switched the browser to Opera on about 8 devices. Never been back since. Shame really it was nice for a while to have similar interfaces on PCs, phones and tablets.

more options

fred.d1 said

Tried disabling high contrast using the method that you suggested and that gets rid of the box effect and the highlighting problem BUT it also means that a number of websites (not all) show dark backgrounds with light text. So in a sense it's progress but not where I want it to be.

High contrast removes many background colors, so that makes sense.

Regarding the page colors, if you don't want to change your toolbar theme to one with dark/black text on the tabs instead of light/white text, you can use the about:config change for a partial solution.

more options

jscher2000 said

Hi bovril602, Firefox 96 is trying to harmonize the color scheme of all the parts of the browser with your toolbar theme. The only "quick fix" is to select a theme that has dark text on the tabs instead of light text. Until someone comes up with a better approach.

Thanks all back to normal. I was using ESAFOX as a theme have gone back to BLUESKY now everything is ok including my bookmarks. Found this out when I updated my Laptop using BLUESKY as it didnt change anything. Damn annoying though!

more options

LucianDK said

I found a fix for the black bookmarks on another site First about:config in a blank page. Click away the warning and add browser.theme.toolbar-theme set it to 1 and voila, the bookmarks is now white with black text without needing to change the theme. This takes out a lot of my annoyance with the new update. But it really shouldnt be needed because mozilla keeps messing with settings and forcing things on the users. Oops. You have to make sure to check use system colors to ensure it works.

It works! Thank you so much.

more options

browser.theme.toolbar-theme = 1 worked like a charm :) Thank you very much!

Has anyone experienced that this parameter is reset to 0 every time I reboot my Linux?

Athraithe ag ps-firefox ar

more options

This is an example of changes that make me very reluctant to allow version updates. Although this fix was relative easy to find and implement, other fixes have taken me hours to find workarounds. So most of the time I just dismiss the reminders - sometimes for months.

more options

I do the same thing Kmershon. I wait too until I am forced to update like when a site just doesn't appear as it should. I am not versed enough to fix it. I rely on this forum when I have an issue. I just don't understand why they have to mess with our settings. Have a great day. Do you hear me Firefox? Please don't mess with my settings.

more options

Hi everyone,

Just popping in here with what I believe is a workable solution to the problem...

The other day I noticed this happening too. Firefox automatically detecting my theme was Dark orientated, to then apply this to general UI elements likewise. But I also wanted to keep these Light themed as I was used to, and so it led me to the workarounds posted.

However, they are only partially solving the issue, such as how the above mentioned preference still (at least for me) causes the Library and menus to appear Dark themed.

In my testing from research, I found that setting browser.theme.toolbar-theme to a value of 1 functionally corrects the issue. But the problem is it's only temporarily so, and upon opening any new window it resets back to the automatic method. That makes it not a permanent solution.

Which got me thinking... What if there is a supported way to LOCK the preference, and force this to always be applied in browser?



Then I came across AutoConfig which is explained in the following Mozilla article: ➡️ https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig

Which functions on the basis of two files:

  • autoconfig.js   = Provides the base setup for custom config rules (establish the framework).
  • firefox.cfg        = Specifies the instructions for the config (tell Firefox what to do).

I read on and then tested creating these as explained. Inside the firefox.cfg file adding the lockPref rule for browser.theme.toolbar-theme and then also additionally browser.theme.content-theme as well. Both with a value of 1 set to force a Light theme. The 2nd preference isn't necessary I found, but I figured with being related it might as well be added too as a precaution.

The key difference here is when applying the locked preference rules, it tells Firefox: Hey, this is what I'd like to keep my settings at. Leave them alone now please!



So based on this, the thought occurred to me how others might wish to learn of this solution too. It got me thinking of the best way to present it, and so I decided to create a tutorial video explaining the process.

Edit: I see my post has seemingly been edited to remove a link to my video! I'll not add the link back unless I clarify this with staff.

So for now, try using your favorite search engine with the terms: How to always use Light Theme in Firefox (AutoConfig Method)

Inside the video description I've linked a zip file containing the two files needed to setup AutoConfig. It is fairly straightforward, and for anyone who wishes to explore, it might even come in useful for other things similarly using the other options.

ℹ️ NOTE: The same principle applies for those who'd wish to force a Dark theme. It'd just involve using a value of 0 instead as the instruction (whereas 1 is for Light as cor-el explained).

Update: Also see this post for details of how to solve the context menus still appear Dark. This happens due to system theming as Windows 10 uses.



Now I'm not trying to be a hero here, but I just wish to share what I found. Also in posting I do so in thanking all of you who do contribute to solutions (as per the replies above). Since oftentimes it goes without a reply, even when coming across such support forums and question answer sites.

Up until hopefully there's a master setting added in Firefox itself, I just hope this might help others too. See attached the pics which show the locked settings, and then the contents of both files.

-CB

Athraithe ag Cyclone Boom ar

more options

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

  1. 1
  2. 2