On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Since last update FF loads as slowly as Chromium based browsers. What changed?

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 15 views
  • Freagra is déanaí ó MrSensible

more options

Since last update FF loads as slowly as Chromium based browsers. What changed?

Since last update FF loads as slowly as Chromium based browsers. What changed?

Réiteach roghnaithe

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 0

All Replies (4)

more options

Réiteach Roghnaithe

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

I rebooted my laptop and that seemed to help. Load to Home page was quicker after reboot. For fun, I tried the Safe Mode restart and it also loads to home page about as fast as after reboot. No idea what was causing the slow loading. Maybe network related, accessing google.com? It's never been this slow loading before, and I can't recall anything else unusual happening beforehand that might be related.

more options

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address bar.

more options

As I said in my prior post, rebooting my laptop seemed to clear it up a bit. Loaded faster. The Safe Mode restart also did about the same. No idea what caused it. Maybe network, but I have a fairly fast internet ISP and wifi router, so not sure. Thanks.