Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Check Spelling not showing english

  • 5 fhreagra
  • 2 leis an bhfadhb seo
  • 47 views
  • Freagra is déanaí ó Dr. Duckling

more options

I have added addons both english GB and US and i added them in the language setting too but no matter what i can't select them in the spell check when spell checking words like this one the only one that appears is Swedish which is my language, i hope you guys can help me because i checked other reports on this issue but as far as i encountered they were already english people using english browser with english spell check or smth like that

I have added addons both english GB and US and i added them in the language setting too but no matter what i can't select them in the spell check when spell checking words like this one the only one that appears is Swedish which is my language, i hope you guys can help me because i checked other reports on this issue but as far as i encountered they were already english people using english browser with english spell check or smth like that

Réiteach roghnaithe

It looks you installed the en-GB and en-US language packs and not a spell check dictionary since you only have the Swedish dictionary. This is a misunderstanding we regularly see happen.

  • name:"English (GB) Language Pack"; type:"locale"; version:"94.0buildid20211103134640"; isActive:true; id:"langpack-en-GB@firefox.mozilla.org";
  • name:"English (US) Language Pack"; type:"locale"; version:"94.0buildid20211103134640"; isActive:true; id:"langpack-en-US@firefox.mozilla.org";

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.


You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

Read this answer in context 👍 1

All Replies (5)

more options

excuse me i wanted to add an image but it didn't work had to convert it to jpg, this is how it looks for me

more options

Réiteach Roghnaithe

It looks you installed the en-GB and en-US language packs and not a spell check dictionary since you only have the Swedish dictionary. This is a misunderstanding we regularly see happen.

  • name:"English (GB) Language Pack"; type:"locale"; version:"94.0buildid20211103134640"; isActive:true; id:"langpack-en-GB@firefox.mozilla.org";
  • name:"English (US) Language Pack"; type:"locale"; version:"94.0buildid20211103134640"; isActive:true; id:"langpack-en-US@firefox.mozilla.org";

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.


You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

Athraithe ag cor-el ar

more options

Hello Cor-el unfortunately i might've not explained it properly, but this is basically the addon i've downloaded https://addons.mozilla.org/en-US/firefox/addon/english-gb-language-pack/

after further reading your reply, i've figured i'm a dumbass, yes you're right, i downloaded the language pack not the dictionary

i'd also like to add to my question then, how can i checkmark both languages (english and swedish) so that it can spell check both without me having to change manually to either each time

Athraithe ag Dr. Duckling ar

more options

Unfortunately you can only select one dictionary at the time, so you would have to switch dictionaries.

more options

Nonetheless thank you very much for your help Cor-el