Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF Ver 92.0

  • 2 fhreagra
  • 1 leis an bhfadhb seo
  • 2 views
  • Freagra is déanaí ó cor-el

more options

Why is my FF keeps on filling up memory even without doing any browsing?

Because my FF started crashing a couple of days ago, I just monitored the Memory Usage on Task Manager. I opened both FF and Edge, without any browsing. Edge is maintaining memory usage at around 129MB (without browsing), but FF keeps on increasing the memory usage. About 20 mins since opening FF, FF memory usage is 3,241 MB (without any browsing at all) and it still keeps climbing as I type.

I am attaching a couple of Task Manager screen shots.

Edge memory usage is up on Image 4 because I am using Edge to type this message.

Can someone please help?

(Current FF memory usage is 3,518 MB - no browsing at all).

I use Win 10 and I'm up to date.

================

Update: (1) I refreshed FF which stopped continuous increase of memory usage (while not browsing). Also, I could see FF lines disappear from Task Manager almost immediately on exiting FF.

(2) To get back "quick launch shortcuts" I copied file "Pref.js" from my old profile. Continuous memory use while idling started again. FF lines were still there on Task Manager after exiting FF.

===============

2nd Update: (I am not a tech savy person) I had a feeling that increasing memory usage while idling on startup (without browsing at all) has something to do with Home Page, website shortcuts. I had about 29 website shortcuts on 4 rows. Did a fresh installation of FF 92.0, deleted all old profiles, and started filling website shortcuts one by one while checking idling memory usage after each shortcut. After creating a shortcut for "https://www.espncricinfo.com/", the idling memory kept on going up and up. I have now removed this website from my shortcuts and the issue appears solved. My browser settings have "Clear cookies on exit" and "Delete history on exit". I use Win 10 64-bit. Can someone please confirm my observation is correct?

Attached screenshots

Athraithe ag Paul ar

All Replies (2)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 Submitted crash reports, and copy them. Now go to the reply box and paste them in.

Please, Do not post a screenshot ! !

aboutcrashesFx57

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Helpful?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.