Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Failure of network requests to various Google services

  • 1 freagra
  • 2 leis an bhfadhb seo
  • Freagra is déanaí ó ThePokyWizard

more options

Edited to add TLDR: some Firefox requests to Google servers seem to fail internally. What can I try to diagnose the problem?

I'm having a recurring problem with Firefox on various Google sites:, Gmail, Calendar, Keep etc. For long periods of time (but not always), Firefox completely fails to load the site, or loses its connection after the page is loaded (for example Gmail displays an error message "Oops... The system encountered a problem (#001)"). The problem usually seems to occur for periods of many minutes, with occasional gaps where the sites work properly. Also, it seems to be site-specific: sometimes it will load normally while Gmail is still having problems. This is really frustrating, I'd like to use Firefox for all my browsing but I also need to use Google services regularly and that doesn't work if Firefox won't load them properly most of the time.

I'm pretty confident it's a problem with Firefox itself, and not with my network or computer, because I get the same issue across multiple Firefox installations and versions (Firefox 90 and 91 on Windows 10, and Firefox 78.10.0esr and 90 on Linux), and while the problem is happening I can access the same sites successfully from a different browser on the same computer (Chrome or Edge). I've tried refreshing my Firefox profile, working in a private browsing window and using a completely new profile, but the problem still occurs. I've also made sure I'm using "Standard" protection in Firefox's security settings and disabled Enhanced Tracking Protection for the sites I'm trying to access.

I've tried to look at what's going on using Firefox's Network Monitor, and the key thing that seems to happen when this problem occurs is that one or more network requests to a google address (, or appear with "0 B" in both the Transferred and Size columns (see screenshot attached). Sometimes the failed network request has a simple padlock icon as in the screenshot, and sometimes a red error symbol with mouseover text that says a security error prevented the resource being loaded. There's also occasionally an error message in the Console: "A ServiceWorker passed a promise to FetchEvent.respondWith() that rejected with 'TypeError: NetworkError when attempting to fetch resource.'.". Removing the relevant service workers in about:serviceworkers doesn't make any difference. On Linux, I've tried using tcpdump to check the actual network traffic and it looks like nothing is actually sent across the network for these requests, so whatever the problem is seems to be happening inside Firefox itself.

Ticking the "Disable Cache" box in the network monitor doesn't help. If I manually resend the same request using the menu in the network monitor, a normal response is received (but the content is not actually displayed in the browser).

It looks to me like some kind of caching or security problem, where Firefox somehow gets in a state where some network requests are blocked or fail to load from a cache, but after a while whatever is causing the problem is cleared and it works normally for a minute or two before the problem recurs. I would simply report this as a bug on Bugzilla, but I can't offer steps for anyone else to reproduce the problem because it only happens when I'm logged into my own Google account. I've run out of ideas for how to diagnose or fix this. Can someone suggest anything else I should try? Thanks!

Attached screenshots

Athraithe ag ColinP ar

All Replies (1)

more options

I also noticed this strange behavior since this Monday (2021-08-09). All Google services have a lag to load (sometimes they don't even load).

I thought it was something related to my anti-virus (MalwareBytes).

Then I thought it was DNS over HTTPS (disabled, but it wasn't).

And the problem occurs on different machines, both on Windows 10 and on macOS.


Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.