Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not rendering PNGs/images

  • 2 fhreagra
  • 1 leis an bhfadhb seo
  • 10 views
  • Freagra is déanaí ó jscher2000

more options

Had this problem for a while. Didn't know how to describe the effect; Firefox renders PNGs as glitched tartan images => screen-caps attached. I'm running 90.0.2. I did a Firefox refresh - the problem still persists. Works fine on Chrome based browsers.

Attached screenshots

Réiteach roghnaithe

Although the appearance is different, it might be a variation of this:

Have you set the privacy.resistFingerprinting preference to true? In that case, Firefox blurs images extracted from a canvas. When you see this problem, you can give the site permission to extract non-blurred images by clicking a little picture-button in the address bar next to the lock icon.

Read this answer in context 👍 1

All Replies (2)

more options

This could be a problem with WebRender or hardware acceleration in Firefox.

You can try to disable WebRender by setting this pref to true on the the about:config page to see if that has effect.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

more options

Réiteach Roghnaithe

Although the appearance is different, it might be a variation of this:

Have you set the privacy.resistFingerprinting preference to true? In that case, Firefox blurs images extracted from a canvas. When you see this problem, you can give the site permission to extract non-blurred images by clicking a little picture-button in the address bar next to the lock icon.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.