Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change Library Font (Ctrl B or Ctrl J)? It's too hard to read

more options

I was able to change the font in Ctrl J by changing my system font (windows 10, Firefox font used to automatically follow it). However after the latest Firefox update, that no longer works for Firefox (my system font is still OK). Please help me change the Libabry font again! The default font (probably SegoeUI) is very hard to read on my computer, it's blurry and comes in light gray.

Note: I'm not talking about the website font (it's fine and can be changed in Firefox settings). The library font size is fine too, only the font itself is too hard to read.

Note2: I tried changing my system font to other random fonts (using the registry), restarting my computer in between etc. That still works, but Firefox won't follow.

Attached screenshots

Réiteach roghnaithe

Firefox 90 has various memory/speed optimizations related to fonts. I suggest checking this one:

Windows Font Substitutions

Previously, the system's font substitutions table was used to override requested fonts, but now the table is only used if the requested font isn't available. Since interface fonts like "Segoe UI" are always available, you get that instead of your preferred font.

Try changing the following preference to revert to the old behavior and see whether this resolves the interface font issue:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.windows-font-substitutes.always and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true -- you might need to do a regular exit/restart of Firefox for that to take effect, I don't have a way to test this

Did that make any difference?

More info on about:config: Configuration Editor for Firefox.

Read this answer in context 👍 1

All Replies (3)

more options

I would try adding this line in the body of one of the paragraphs in your profile's (about:profiles) chrome/userChrome.css file:

font-family: "Segoe UI" !important;

https://developer.mozilla.org/en-US/docs/Web/CSS/font-family https://docs.microsoft.com/en-us/typography/fonts/windows_10_font_list

If that does not work I would try running Firefox in WSL2.

Helpful?

more options

Réiteach Roghnaithe

Firefox 90 has various memory/speed optimizations related to fonts. I suggest checking this one:

Windows Font Substitutions

Previously, the system's font substitutions table was used to override requested fonts, but now the table is only used if the requested font isn't available. Since interface fonts like "Segoe UI" are always available, you get that instead of your preferred font.

Try changing the following preference to revert to the old behavior and see whether this resolves the interface font issue:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.windows-font-substitutes.always and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true -- you might need to do a regular exit/restart of Firefox for that to take effect, I don't have a way to test this

Did that make any difference?

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

Thanks jscher2000, you're a legend!

@JP: Using CSS you need to change the font for each part of the brower. Entering [font-family: "Arial" !important;] itself doesn't do anything. I can change most things but not Ctrl D, right click, and the organize line in the library (and probably some others I haven't noticed yet), resulting in a mishmash of the desired font and Segoe UI.

jscher2000's solution is complete and much easier to do.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.