Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Transparent dropdown menus after upgrade to Firefox 90

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 267 views
  • Freagra is déanaí ó Psimonics

more options

I just upgraded from FF 89 to FF 90 (on Ubuntu) and the drop down menus (accessed on right-click) are now transparent. I have changed the theme, changed my desktop theme, started FF in troubleshoot mode, disabled acceceration in about:config, and it makes no difference, the menus are still transparent. This makes it difficult to use the browser.

Is this fixable or is it a bug in the latest release?

Attached screenshots

Réiteach roghnaithe

Update: I found the fault was in theme I was using. I had switched themes before to test if that was the source but it seems the change wasn't fully applied to Firefox. So not something in Firefox. Thanks.

Read this answer in context 👍 0

All Replies (6)

more options

PS. I also started with a fresh profile and the issue persists

Helpful?

more options

You can try to disable WebRender by setting this pref to true on the the about:config page to see if that has effect.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Helpful?

more options

Hello and thank you for your reply.

I'm afraid the issue persists after trying both solutions.

Simon

Helpful?

more options

Réiteach Roghnaithe

Update: I found the fault was in theme I was using. I had switched themes before to test if that was the source but it seems the change wasn't fully applied to Firefox. So not something in Firefox. Thanks.

Athraithe ag Psimonics ar

Helpful?

more options

I'm still having this issue after downloading the Mozilla compiled version, using a clean configuration, etc.

No installed themes used, no addons, and its still having the issue.

It is annoying but the browser still works. Any idea when the theme issue is going to be fixed?

Helpful?

more options

@adnieman

Have you tried changing your desktop theme? In my case it was the GTK 3 theme I was using that generated the issue. I can't find where, I'm not techie enough, but changing my desktop theme worked.

I suspect a few GTK themes will not work with the latest firefox interface., as I found that accessing "about:config" from the address bar, searching for "browser.proton.enabled" and marking to "false" solved the issue with the offending theme. It restores firefox to the previous pre-89 interface.

Update: I found that you need to make sure the GTK3 theme gtk.css file in the theme folder contains a setting for the menu background colour. Eg. Mine is:

menu {

   background-color: @base_color;

}

Adding the line "background-color: @base_color;" to the above menu section fixes the clear menu issue.

Hope this helps, Simon

Athraithe ag Psimonics ar

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.